1163 Dijkstra Sequence

Dijkstra's algorithm is one of the very famous greedy algorithms.
It is used for solving the single source shortest path problem which gives the shortest paths from one particular source vertex to all the other vertices of the given graph. It was conceived by computer scientist Edsger W. Dijkstra in 1956 and published three years later.

In this algorithm, a set contains vertices included in shortest path tree is maintained. During each step, we find one vertex which is not yet included and has a minimum distance from the source, and collect it into the set. Hence step by step an ordered sequence of vertices, let's call it Dijkstra sequence, is generated by Dijkstra's algorithm.

On the other hand, for a given graph, there could be more than one Dijkstra sequence. For example, both { 5, 1, 3, 4, 2 } and { 5, 3, 1, 2, 4 } are Dijkstra sequences for the graph, where 5 is the source. Your job is to check whether a given sequence is Dijkstra sequence or not.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers Nv​ (≤103) and Ne​ (≤105), which are the total numbers of vertices and edges, respectively. Hence the vertices are numbered from 1 to Nv​.

Then Ne​ lines follow, each describes an edge by giving the indices of the vertices at the two ends, followed by a positive integer weight (≤100) of the edge. It is guaranteed that the given graph is connected.

Finally the number of queries, K, is given as a positive integer no larger than 100, followed by K lines of sequences, each contains a permutationof the Nv​ vertices. It is assumed that the first vertex is the source for each sequence.

All the inputs in a line are separated by a space.

Output Specification:

For each of the K sequences, print in a line Yes if it is a Dijkstra sequence, or No if not.

Sample Input:

5 7
1 2 2
1 5 1
2 3 1
2 4 1
2 5 2
3 5 1
3 4 1
4
5 1 3 4 2
5 3 1 2 4
2 3 4 5 1
3 2 1 5 4

Sample Output:

Yes
Yes
Yes
No

题目大意:

给定一个图 要你求这个图是否是Dijkstra序列

注意: 

在每一步中,我们找到一个尚未在集合内且与源顶点距离最小的顶点,并将其收于集合中

AC代码:

/*
* @Author: Spare Lin
* @Project: AcWing2022
* @Date: 2022/6/28 18:44
* @Description: 4275. Dijkstra序列 来源:PAT甲级真题1163
*/

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXN = 1e3 + 7;
int n, m; //点和边
int dis[MAXN], g[MAXN][MAXN];
bool vis[MAXN];
int q[MAXN];//输入的序列

bool Dijkstra() {
    memset(dis, 0x3f, sizeof(dis));
    memset(vis, 0, sizeof(vis));

    dis[q[0]] = 0;

    for (int i = 0; i < n; ++i) {
        int t = q[i];
        for (int j = 1; j <= n; ++j) {
            //若当前点没被访问过且存在一个点比当前点更小
            if (!vis[j] && dis[j] < dis[t]) {
                return false;
            }
        }
        vis[t] = true;
        //更新当前近的点
        for (int j = 1; j <= n; ++j) {
            dis[j] = min(dis[j], dis[t] + g[t][j]);
        }
    }
    return true;
}

int main() {
    scanf("%d%d", &n, &m);
    memset(g, 0x3f, sizeof(g));
    while (m--) {
        int x, y, val;
        scanf_s("%d%d%d", &x, &y, &val);
        g[x][y] = g[y][x] = val;
    }
    int k;
    scanf("%d", &k);
    while (k--) {
        for (int i = 0; i < n; ++i) {
            scanf("%d", &q[i]);
        }
        printf(Dijkstra() ? "Yes\n" : "No\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值