H106OJ 前10名问题

Description

数据很多,但我们经常只取前几名,比如奥运只取前3名。现在我们有n个数据,请按从大到小的顺序,输出前10个名数据。

Input

输入两行。

第一行一个整数n,表示要对多少个数据;

第二行有n个整数,中间用空格分隔。表示n个数据。

Sample Input 

26
54 27 87 16 63 40 40 22 61 6 57 70 0 42 11 50 13 5 56 7 8 86 56 91 68 59

Output

输出一行,按从大到小排列的前10个数据,每个数据之间用一个空格隔开。

Sample Output

91 87 86 70 68 63 61 59 57 56

思路

首先我们看到这个问题会想到排序,排序有很多种(直接排序,冒泡排序,希尔排序,快速排序,选择排序,堆排序,归并排序),这里选择用了冒泡排序,其基本思想是:两两比较相邻记录,如果反序则交换,直到没有反序的记录为止。

代码:

c++:
#include<iostream>
using namespace std;
const int MaxSize=100;
 
class Sort{
public:
	Sort();
	void BubbleSort();
	void Print();
private:
	int data[MaxSize];
	int length;	
}; 

Sort::Sort(){
	cin>>length;
	for(int i=0;i<length;i++)
		cin>>data[i];
} 

void Sort::Print(){
	for(int i=0;i<10;i++){
		cout<<data[i]<<" ";
	}
} 

void Sort::BubbleSort(){
	int i,exchange,bound,temp;
	exchange=length-1;
	while(exchange!=0){
		bound=exchange;
		exchange=0;
		for(i=0;i<bound;i++)
			if(data[i]<data[i+1]){
				temp=data[i];
				data[i]=data[i+1];
				data[i+1]=temp;	
				exchange=i; 
			}	
	 }
}

int main(){
	Sort A;
	A.BubbleSort();
	A.Print();
	return 0;
}


Java:
import java.util.Scanner;
public class Main {
	public static void main(String[] args){
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int[]a = new int[n];
		for(int i = 0; i < n; i++){
			a[i] = sc.nextInt();
		}
		for(int i = 0; i < n-1; i++){
			for(int j = n-1; j > 0; j--){
				if(a[j] > a[j-1]){
					int temp = a[j];
					a[j] = a[j-1];
					a[j-1] = temp;
				}
			}
		}
		for(int i = 0; i < 10; i++){
			System.out.print(a[i]+" ");
		}
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这道题目的大致思路如下: 1. 首先读入原有文件中的数据,并将其保存到一个数组中; 2. 读入要插入的数据,并将其插入到数组中相应的位置; 3. 将数组中的数据写回到原有文件中。 下面是一个可能的实现: ```c++ #include <iostream> #include <fstream> #include <vector> using namespace std; struct Record { int id; string name; int age; }; int main() { // 读入原有文件中的数据 vector<Record> records; ifstream fin("data.txt"); if (fin.is_open()) { int id, age; string name; while (fin >> id >> name >> age) { records.push_back({id, name, age}); } fin.close(); } // 读入要插入的数据 Record new_record; cin >> new_record.id >> new_record.name >> new_record.age; // 将新数据插入到数组中相应的位置 int pos = -1; for (int i = 0; i < records.size(); ++i) { if (records[i].id > new_record.id) { pos = i; break; } } if (pos == -1) { records.push_back(new_record); } else { records.insert(records.begin() + pos, new_record); } // 将数组中的数据写回到原有文件中 ofstream fout("data.txt"); if (fout.is_open()) { for (const auto& record : records) { fout << record.id << " " << record.name << " " << record.age << "\n"; } fout.close(); } return 0; } ``` 其中,我们定义了一个 `Record` 结构体来表示每一条记录,然后使用一个 `vector` 来保存所有的记录。在读入原有文件中的数据时,我们使用了文件读取流 `ifstream`,在写回到文件中时,我们使用了文件写入流 `ofstream`。读入要插入的数据时,我们直接使用标准输入流 `cin`。 在将新数据插入到数组中时,我们首先需要找到相应的位置。这里我们使用了一种简单的方法,即遍历数组,找到第一个 ID 大于新数据 ID 的位置,然后将新数据插入到该位置。如果没有找到这样的位置,说明新数据 ID 是最大的,我们将其追加到数组末尾即可。在将新数据插入到数组中时,我们使用了 `vector` 的 `insert` 方法。 最后,我们将数组中的数据写回到原有文件中。在写回到文件中时,我们使用了 `ofstream` 的输出流运算符 `<<`。由于每条记录都需要以一行的形式写入文件,因此我们在输出时需要加上换行符 `\n`。 希望这个解答能够帮助到你!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值