PAT A1022 Digital Library数字图书馆C++

文章描述了一个C++编程任务,要求构建一个数字图书馆的数据库,包含书籍信息如ID、作者、关键词等,并能按ID排序输出查询结果。输入输出规范详细定义了数据结构和查询方式,包括按书名、作者、关键词、出版社和年份查询。示例展示了输入输出样例。
摘要由CSDN通过智能技术生成

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;

  • Line #2: the book title -- a string of no more than 80 characters;

  • Line #3: the author -- a string of no more than 80 characters;

  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;

  • Line #5: the publisher -- a string of no more than 80 characters;

  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title

  • 2: name of an author

  • 3: a key word

  • 4: name of a publisher

  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

这个题目就是单纯的很烦很烦 简而言之就是用C++实现一个数据库 有好多个需要注意的点 分值完全是代码长度堆积出来的,还有很多东西的高级用法 属于边写边学系列

注意的点:

  1. streamstring头文件为sstream

  1. set的插入用insert而不是pushback

  1. 用getline之前一定要用getchar吸收掉换行符

  1. a.substr(b)是指截取b后面的所有元素

  1. for(auto &book:books)这种遍历要学会

  1. book.keywords.count(info)计算set里面每一元素的数量

#include<iostream>
#include<vector>
#include<set>
#include<sstream>
#include<algorithm>
using namespace std;

struct Book
{
    string id,name,author;
    set<string> keywords;
    string publisher,year;
};
vector<Book> books;

int main()
{
    int n,m;cin>>n;
    while(n--)
    {
        string id,name,author,publisher,year,keyword;
        cin>>id;
        getchar();
        getline(cin,name);
        getline(cin,author);
        string line;
        getline(cin,line);
        stringstream ssin(line);
        set<string> keywords;
        while(ssin>>keyword) keywords.insert(keyword);
        getline(cin,publisher);
        cin>>year;
        books.push_back({id, name, author, keywords, publisher, year});
    }
    cin>>m; getchar();
    while(m--)
    {
        string s;
        vector<string> res;
        getline(cin,s);
        cout<<s<<endl;
        char t=s[0];
        string info=s.substr(3);
        if(t=='1')
        {
            for(auto &book:books)
            {
                if(info==book.name)
                    res.push_back(book.id);
            }
        }
        if(t=='2')
        {
            for(auto &book:books)
            {
                if(info==book.author)
                    res.push_back(book.id);
            }
        }
        if(t=='4')
        {
            for(auto &book:books)
            {
                if(info==book.publisher)
                    res.push_back(book.id);
            }
        }
        if(t=='5')
        {
            for(auto &book:books)
            {
                if(info==book.year)
                    res.push_back(book.id);
            }
        }
        if(t=='3')
        {
            for(auto &book:books)
            {
                if(book.keywords.count(info))
                    res.push_back(book.id);
            }
        }
        if(res.size()==0) puts("Not Found");
        else{
            sort(res.begin(),res.end());
            for(int i=0;i<res.size();++i)
                cout<<res[i]<<endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值