和大家分享一下,用字典序的写法,对于1e5的数据,明知道会超时,但还是忍不住这样写;不超时可以用BFS的写法
利用字典序的最后一个结点向上寻找、记录
比如这样的,就把5、6、10、12、8、9记录下来,不断向上查找、可找到最长路径及其所经过的结点;
L2-026 小字辈 (25 分)
本题给定一个庞大家族的家谱,要请你给出最小一辈的名单。
输入格式:
输入在第一行给出家族人口总数 N(不超过 100 000 的正整数) —— 简单起见,我们把家族成员从 1 到 N 编号。随后第二行给出 N 个编号,其中第 i 个编号对应第 i 位成员的父/母。家谱中辈分最高的老祖宗对应的父/母编号为 -1。一行中的数字间以空格分隔。
输出格式:
首先输出最小的辈分(老祖宗的辈分为 1,以下逐级递增)。然后在第二行按递增顺序输出辈分最小的成员的编号。编号间以一个空格分隔,行首尾不得有多余空格。
输入样例:
9
2 6 5 5 -1 5 6 4 7
输出样例:
4
1 9
#include<iostream>
#include<algorithm>
#include<cstring>
#include<set>
#include<unordered_map>
#include<vector>
#include<stack>
#define x first
#define y second
using namespace std;
typedef long long ll;
typedef pair<int , string> PII;
const int N = 1e5 + 20;
int n, maxx, fa[N], son[N];
vector <int>a, res;
int main(){
scanf("%d", &n);
for (int i = 1; i <= n; i++)
{
int f;
scanf("%d", &f);
fa[i] = f;
if (f != -1) son[f] = 1;
}
for (int i = 1; i <= n; i++)
if (!son[i]) a.push_back(i);
for (int i = 0; i < a.size(); i++)
{
int p = a[i], cnt = 1;
while (fa[p] != -1)
{
cnt++;
p = fa[p];
}
if (cnt > maxx)
{
maxx = cnt;
res.clear();
res.push_back(a[i]);
}
else if (cnt == maxx) res.push_back(a[i]);
}
sort(a.begin(), a.end());
printf("%d\n", maxx);
for (int i = 0; i < res.size(); i++)
{
printf("%d", res[i]);
if (i < res.size() - 1) printf(" ");
}
return 0;
}
对于类似题型还有天梯赛有好些题都是这样的,
比如—L2-038 病毒溯源 (25 分) 对于1e4的数据没有超时;
分享一下 病毒溯源的代码:如下
#include<iostream>
#include<algorithm>
#include<cstring>
#include<unordered_set>
#include<map>
#include<vector>
#define x first
#define y second
using namespace std;
typedef long long ll;
typedef pair<vector<int> , int> PII;
const int N = 1e4 + 10;
int fa[N], a[N];
vector <int> res;
int n, k;
int main()
{
int cnt = 0;
scanf("%d", &n);
for (int i = 0; i < n; i++) fa[i] = i;
for (int i = 0; i < n; i++)
{
scanf("%d", &k);
if (!k) a[cnt++] = i;
while (k--)
{
int x;
scanf("%d", &x);
fa[x] = i;
}
}
int maxx = 0;
for (int i = 0; i < cnt; i++)
{
int x = a[i];
vector<int> t;
while (fa[x] != x)
{
t.push_back(x);
x = fa[x];
}
t.push_back(x);
reverse(t.begin(), t.end());
if (maxx < t.size()) maxx = t.size(), res = t;
else if (maxx == t.size() && res > t) res = t;
t.clear();
}
printf("%d\n", res.size());
for (int i = 0; i < res.size(); i++)
{
printf("%d", res[i]);
if (i < res.size() - 1) printf(" ");
}
return 0;
}
还有一些其他题也可以这样做,但一般来说会超时;
上面就分享了这两道题;;
如有错误,希望大哥们指出来!