字符串循环左移PTA三种方法

输入一个字符串和一个非负整数N,要求将字符串循环左移N次。

输入格式:

输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。

输出格式:

在一行中输出循环左移N次后的字符串。

样例:">输入样例:

Hello World!
2

输出样例:

llo World!He

1. 利用第二个数组储存

#include <stdio.h>
#include <string.h>
int main(){
    char ch[101];
    int i=0;
    while((ch[i]=getchar())!='\n'){
        i++;
    }
    ch[i]='\0';
    int n;
    scanf("%d",&n);
    n%=i;
    char arr[101];
    for(int j=0;j<n;j++){
        arr[j]=ch[j];
    }
    for(int j=n;j<i;j++){
        ch[j-n]=ch[j];
    }
    int k=0;
    for(int j=i-n;j<i;j++){
        ch[j]=arr[k++];
    }
    printf("%s",ch);
    return 0;
}

2.直接打印

#include <stdio.h>
#include <string.h>
int main(){
    char ch[101];
    gets(ch);
    int i=strlen(ch);
    int n;
    scanf("%d",&n);
    n%=i;
    char arr[101];
    for(int j=n;j<i;j++){
        printf("%c",ch[j]);
    }
    for(int j=0;j<n;j++){
        printf("%c",ch[j]);
    }
    return 0;
}

3.利用类似冒泡的循环依次交换元素 

#include <stdio.h>
#include <string.h>
int main(){
    char ch[101];
    gets(ch);
    int i=strlen(ch);
    int n;
    scanf("%d",&n);
    n%=i;
    char arr[101];
    char temp;
    for(int j=0;j<n;j++){
        for(int k=0;k<i-1;k++){
            temp=ch[k];
            ch[k]=ch[k+1];
            ch[k+1]=temp;
        }
    }
    printf("%s",ch);
    return 0;
}

 

  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值