题目描述
读入一个字符串,按单词将该字符串逆序,比如给定"This is a sentence",则输出是"sentence a is This",为了简化问题,字符串中不包含标点符号。
样例输入content_copy
This is a sentence
样例输出content_copy
sentence a is This
代码实现:
#include<bits/stdc++.h>
using namespace std;
int cnt;
string s,a[1000];
int main(){
getline(cin,s);
for(int i=0;i<s.size();i++){
string temp="";
while(s[i]!=' '){
temp=temp+s[i];
i++;
if(i==s.size()) break;
}
a[cnt++]=temp;
}
for(int i=cnt-1;i>=0;i--) cout<<a[i]<<' ';
return 0;
}