颠倒的句子

题目描述

读入一个字符串,按单词将该字符串逆序,比如给定"This is a sentence",则输出是"sentence a is This",为了简化问题,字符串中不包含标点符号。

样例输入content_copy

This is a sentence

样例输出content_copy

sentence a is This

 代码实现:

#include<bits/stdc++.h>
using namespace std;
int cnt;
string s,a[1000];
int main(){
	getline(cin,s);
	for(int i=0;i<s.size();i++){
		string temp="";
		while(s[i]!=' '){
			temp=temp+s[i];
			i++;
			if(i==s.size()) break;
		}
		a[cnt++]=temp;
	}
	for(int i=cnt-1;i>=0;i--) cout<<a[i]<<' ';
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值