2021-08-10关于航电ACM题库1.2.6题中变量问题反思(萌新)

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9607 Accepted Submission(s): 2891

Problem Description

The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.

Output

For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input

4
+ 1 2
- 1 2
* 1 2
/ 1 2

Sample Output

3
-1
2
0.50

Author

lcy

最开始的调试:

#include <stdio.h>

#include <math.h>

int T=0;

int main()

{    

    int a,b;

    double sum=0.0;

    char c;

    scanf("%d",&T);

    while (T>0)

    {

        scanf("%s",&c);

        scanf("%d%d",&a,&b);

        if(c=='+') {sum=a+b;printf("%d\n",sum);}

        if(c=='-') {sum=a-b;printf("%dn",sum);}

        if(c=='*') {sum=a*b;printf("%d\n",sum);}

        if(c=='/') {sum=a/b;if(floor(sum)==sum) {printf("%d\n",sum);} else {printf("%.02f\n",sum);}} 

        T--;

    }

    return 0;

}

但经调试,发现因为sum为双精度变量,当用%d输出时会出现问题,输出的总是0,于是我将%d改为%.0f。

再次调试,发现执行1/2时输出为0,猜测与a、b、sum的变量定义类型有关,因为a,b为整数型,于是a/b=0。

将a,b改为双精度类型,发现输入1和2时失败,a,b并未成功赋值。试图将scanf("%d%d",&a,&b);改为scanf("%f%f",&a,&b);也没有作用。最后决定用强制类型转换,程序改为:

#include <stdio.h>

#include <math.h>

int T=0;

int main()

{

    int a,b;

    double sum=0.0;

    char c;

    scanf("%d",&T);

    while (T>0)

    {

        scanf("%s",&c);

        scanf("%d%d",&a,&b);

        if(c=='+') {sum=a+b;printf("%.0f\n",sum);}

        if(c=='-') {sum=a-b;printf("%.0f\n",sum);}

        if(c=='*') {sum=a*b;printf("%.0f\n",sum);}

        if(c=='/') {sum=(double)a/(double)b;if(floor(sum)==sum) {printf("%.0f\n",sum);} else {printf("%.02f\n",sum);}} 

        T--;

    }

    return 0;

}

最后完成。

(总感觉可以再简单点)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

L.K.2

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值