1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

思路: 首先有几个窗口只需要对前几个窗口进行特殊处理即可,也就是这个人如果超过8.00,那么就不需要等,如果不超过的话就把等待时间加上这一段时间,然后定义一个优先队列(维护的是每一个人办理完的时间),不断弹出完成最快的那一个,然后把最早来的那一个给弄进来。如果他到达的时间大于目前优先队列队首,那么就不对等待时间做处理,如果到达的时间小于优先队列队首,那么等待时间就需要加上优先队列队首时间-当前这个人到达的时间。

代码:

#include <bits/stdc++.h>
using namespace std;
struct person{
    int time;
    int pro;
};
bool compare(person a,person b){
    return a.time<b.time;
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    int i;
    person a[n];
    int tt=17*3600;
    int t=8*3600;
    for(i=0;i<n;i++){
        int hour,minute,second,value;
        scanf("%d:%d:%d%d",&hour,&minute,&second,&value);
        if(value>60)value=60;
        a[i].time=hour*3600+minute*60+second;//同一单位
        a[i].pro=value;
    }
    sort(a,a+n,compare);
    double ans=0;
    priority_queue<int,vector<int>,greater<int>>take;
    for(i=0;i<n;i++){
        if(a[i].time>tt)break;
        if(i<m){
            if(a[i].time<t){
                ans=ans+t-a[i].time;
                take.push(t+a[i].pro*60);//分钟转化为秒
            }
            else take.push(a[i].time+a[i].pro*60);
        }
        else {
            if(a[i].time>=take.top()){
                    take.push(a[i].time+a[i].pro*60);
            }
            else {
                take.push(take.top()+a[i].pro*60);
                ans=ans+take.top()-a[i].time;
            }
            take.pop();
        }
    }
    printf("%.1lf",ans/60/(i));
    system("pause");
}

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值