统计单词

目录

描述

输入

输出

样例输入

样例输出

code 1 (存在问题,因为cin遇到空格是有问题的)

code 2(map)


描述

统计单词的升级版。输入一段话含多个单词,以enter结束。输入单词全部为大小写英文字母组成。统计单词出现的频度。

输入

本题有多组测试数据,输入一段话含多个单词,以enter结束。输入单词全部为大小写英文字母组成。

输出

以字典序列输出单词及频度列表。每个词一行

样例输入
hello world hello acmer
样例输出
acmer 1
hello 2
world 1

code 1 (存在问题,因为cin遇到空格是有问题的)

#define _CRT_SECURE_NO_WARNINGS 1
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
int main()
{
    string input;

    while (cin >> input) {
        map<string, int> mp;
        string ans;
        for (int i = 0; i < input.size(); i++) {
            if (ans.empty() || input[i]!=' ') ans.push_back(input[i]);
            else {
                mp[ans]++;
                ans.clear();
            }
        }
        mp[ans]++;
        for (auto it = mp.begin(); it != mp.end(); it++) {
            cout << it->first << ' ' << it->second<<endl;
        }
        /
    }
    return 0;
}

code 2(map)

#define _CRT_SECURE_NO_WARNINGS 1
#include <iostream>
#include <map>
#include <string>
#include <sstream>
#include <algorithm>
using namespace std;

int main()
{
    string input;

    while (getline(cin, input)) {
        istringstream iss(input);
        map<string, int> mp;
        string word;
        while (iss >> word) {
            mp[word]++;
        }
        for (auto it = mp.begin(); it != mp.end(); it++) {
            cout << it->first << " " << it->second << endl;
        }
        //第二种写法
        map<string, int>::iterator it;
        for (it = mp.begin(); it != mp.end(); it++) {
            cout << it->first << ' ' << it->second << endl;
        }
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值