问题 J: 逆转单词1259

题目描述

对于每个单词列表,输出一行,把每个单词都反转而不改变单词的顺序。此问题包含多个测试用例!多输入的第一行是整数N。每个输入块的格式都在问题描述中。

输入

你将获得一些测试用例。第一行包含一个正整数,表示要遵循的案例数。每个案例都在一行中给出,该行包含由一个空格分隔的单词列表,每个单词仅包含大写和小写字母。

输出

对于每个测试用例,请在一行上输出

样例输入 Copy

3
I am happy today
To be or not to be
I want to win the practice contest

样例输出 Copy

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

提示:遇到字母入栈,遇到空格使先前入栈的字母出栈

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node
{
	char s[9999];
	int top;
}stack;
void push(stack *p,char c);
char pop(stack *p);
int isempty(stack p);
int main()
{
	char c[9999];
	stack p;
	p.top=0;
	int t;
	scanf("%d",&t);
	getchar();
	while(t>0)
	{
		gets(c);
		int len=strlen(c);
		for(int i=0;i<len;i++)
		{
			if(c[i]!=' ')
			{
				push(&p,c[i]);
			}
			if(c[i]==' ')
			{
				while(isempty(p)==1)
				{
					printf("%c",pop(&p));
				}
				printf(" ");
			}
		}
		while(isempty(p)==1)
			printf("%c",pop(&p));
		printf("\n");
		t--;
	}
	return 0;
}
void push(stack *p,char c)
{
	p->top++;
	p->s[p->top]=c;
}
char pop(stack *p)
{
	char c=p->s[p->top];
	p->top--;
	return c;
}
int isempty(stack p)
{
	if(p.top==0)return 0;
	else return 1;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

YYDGM1

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值