2019山东省赛 K - Happy Equation(数论)

题目链接:

ZOJ (pintia.cn)

题目内容:

Little Sub has just received an equation, which is shown below, as his birthday gift.

Given the value of , please help Little Sub count the number of x(1<=x<=2^p)
which satisfies the equation.

Input

There are multiple test cases. The first line of the input contains an integer T (about 1000), indicating the number of test cases. For each test case:
The first and only line contains two integers a and p (1<=a<=10^9, 1<=p<=30).

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

2
6 12
8 16

Sample Output

1023
16383

 在这里插入图片描述

打表一下会发现:

当n为奇数是,只有一个满足题意;

#include<bits/stdc++.h>
using namespace std;
const int N=1e6+10;
#define int long long
int ksm(int x,int y,int p){
	int res=1;
	while(y){
		if(y&1) res=res*x%p;
		x=x*x%p;
		y/=2;
	}
	return res%p;
}
signed main(){
	int t;
	cin>>t;
	while(t--){
		int n,p;
		cin>>n>>p;
		if(n%2==1) {
			cout<<"1\n";
			continue;
		} 
		else{
			int ans=0;
			int mod=1<<p;
			for(int i=1;i<=p;i++){
				if(ksm(n,i,mod)%mod==ksm(i,n,mod)%mod){
					ans++;
				}
			}
			int op=p/n;
			if(p%n) op++;
			int l=1<<op;
			ans+=(mod/l-p/l);
			cout<<ans<<"\n";
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值