SWUST OJ955: 单链表上查找算法的实现

题目描述

建立一个长度为n的带头结点的单链表,在该表中寻找第i个结点,若找到,则输出ok,否则输出error。处理数据类型为整型。

输入

第一行为链表的长度n;
第二行为链表中的数据元素;
第三行为要找的结点i。

输出

找到就输出ok,没找到就输出error。

样例输入

10
1 2 3 4 5 6 7 8 9 10
5

样例输出

ok
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<malloc.h>
#define INF 0x3f3f3f3f
#define MAX(x,y) (x>y?x:y)
#define MIN(x,y) (x>y?y:x)
#define M 10001
int flag = 1;
typedef struct LNode
{
    int data;
    struct LNode* next;
}LNode;
int searchLNode(LNode* L, int m,int n)
{
    if (m<1 || m>n)
    {
        return 0;
    }
    return 1;
}
int main()
{
    LNode* L;
    L = (LNode*)malloc(sizeof(LNode));
    int n;
    scanf("%d", &n);
    L->next = NULL;
    LNode* temp = L;
    for (int i = 0; i < n; i++)
    {
        LNode* p = (LNode*)malloc(sizeof(LNode));
        scanf("%d", &p->data);
        p->next = NULL;
        temp->next = p;
        temp = p;
    }
    int m;
    scanf("%d", &m);
    int h=searchLNode(L, m,n);
    if (h == 1)
    {
        printf("ok");
    }
    else
    {
        printf("error");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值