A - Smallest Sub-Array

Consider an integer sequence consisting of N elements where

X1 = 1

X2 = 2

X3 = 3

Xi = (Xi−1 + Xi−2 + Xi−3)%M + 1                                  for i = 4 to N Find 2

values a and b so that the sequence (Xa Xa+1 Xa+2 . . . Xb−1Xb) contains all the integers from [1, K]. If there are multiple solutions then make sure (b − a) is as low as possible.

In other words, find the smallest subsequence from the given sequence that contains all the integers from 1 to K.

Consider an example where N = 20, M = 12 and K = 4.

The sequence is {1 2 3 7 1 12 9 11 9 6 3 7 5 4 5 3 1 10 3 3}.

The smallest subsequence that contains all the integers {1 2 3 4} has length 13 and is highlighted in the following sequence:

{1 2 3 7 1 12 9 11 9 6 3 7 5 4 5 3 1 10 3 3}.

Input

First line of input is an integer T (T < 100) that represents the number of test cases. Each case consists of a line containing 3 integers N (2 < N < 1000001), M (0 < M < 1001) and K (1 < K < 101). The meaning of these variables is mentioned above.

Output

For each case, output the case number followed by the minimum length of the subsequence. If there is no valid subsequence, output ‘sequence nai’ instead. Look at the sample for exact format.

Sample Input

2

20 12 4

20 12 8

Sample Output

Case 1: 13

Case 2: sequence nai

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[1000005],vis[1000005];
const int maxn=1000000+10;
int main()
{
	int t;
	scanf("%d",&t);
	int n,m,k,casenum=1,ans;
	a[1]=1;
	a[2]=2;
	a[3]=3;
	while(t--)
	{
		ans=maxn; 
		scanf("%d %d %d",&n,&m,&k);
		for(int i=4;i<=n;i++)
		{
			a[i]=(a[i-3]+a[i-2]+a[i-1])%m+1;
		}
		memset(vis,0,sizeof vis);
		int l=1,r=1;
		int cnt=0;
		while(cnt<k&&r<=n)
		{
			if(a[r]<=k)
			{
				if(vis[a[r]]==0)
				cnt++;
				vis[a[r]]++;
			}
			r++;
		}
		if(cnt<k)
		{
			printf("Case %d: sequence nai\n",casenum);
			casenum++;
			continue;
		}
		--r;
		ans=r-l+1;
		while(r<=n)
		{
			ans=min(ans,(r-l+1));
			if(a[l]<=k)
			{
				if(vis[a[l]]>1)
				{
					vis[a[l]]--; 
					l++; 
				}
				else 
				{ 
					r++; 
					vis[a[r]]++; 
				}
			}
			else
			l++;
		}
		printf("Case %d: %d\n",casenum,ans);
		casenum++;
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值