PAT 甲级 1004 Counting Leaves C++

题目描述:

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.


Sample Input:

2 1
01 1 02

Sample Output:

0 1

解体思路:

我们可以定义结构体node:

struct node
{
	int level;
	vector<int> child;
};

包含层数和子树,层数在入队时定义就行,是父节点的层数加一;

构建树的代码:

for (int i = 0; i < m; i++)
	{
		string str;
		cin >> str;

		int root;
		root = stoi(str);

		int k;
		cin >> k;

		for (int j = 0; j < k; j++)
		{
			string temp;
			cin >> temp;

			int son = stoi(temp);
			v[root].child.push_back(son);
		}
	}

这里用到了函数stoi(string str),把string转化成int

关键是如何数每层的叶子数:

我们可以设置一个数组ans(存放数据),还有最大层数maxlevel(在输出时可以确定上界);

用队列把每个节点遍历一遍,更新每个节点的层数,数的最大层数,要初始化01的层数为一

void count(int first)
{
	q.push(first);
	v[first].level = 1;

	while (!q.empty())
	{
		int now = q.front();
		q.pop();

		if (v[now].child.empty())
		{
			ans[v[now].level]++;
			if (v[now].level > maxlevel)
			{
				maxlevel = v[now].level;
			}
		}
		else
		{
			for (int i = 0; i < v[now].child.size(); i++)
			{
				q.push(v[now].child[i]);
				v[v[now].child[i]].level = v[now].level + 1;
			}
		}
	}
}

 完整代码:

#include <bits/stdc++.h>
using namespace std;

#define maxlen 101

struct node
{
	int level;
	vector<int> child;
};

node v[maxlen];
int ans[maxlen];
queue<int> q;
int maxlevel = -1;

void count(int first)
{
	q.push(first);
	v[first].level = 1;

	while (!q.empty())
	{
		int now = q.front();
		q.pop();

		if (v[now].child.empty())
		{
			ans[v[now].level]++;
			if (v[now].level > maxlevel)
			{
				maxlevel = v[now].level;
			}
		}
		else
		{
			for (int i = 0; i < v[now].child.size(); i++)
			{
				q.push(v[now].child[i]);
				v[v[now].child[i]].level = v[now].level + 1;
			}
		}
	}
}

int main()
{
	int n, m;
	cin >> n >> m;

	for (int i = 0; i < m; i++)
	{
		string str;
		cin >> str;

		int root;
		root = stoi(str);

		int k;
		cin >> k;

		for (int j = 0; j < k; j++)
		{
			string temp;
			cin >> temp;

			int son = stoi(temp);
			v[root].child.push_back(son);
		}
	}

	count(1);

	cout << ans[1];

	for (int i = 2; i <= maxlevel; i++)
	{
		cout << " " << ans[i];
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值