问题 I: 括号匹配问题

题目描述

判断仅由小括号组成的字符串是否满足括号匹配规则

输入格式

输入包括多行,每行一个仅有小括号组成的字符串,长度不超过100

输出格式

输出包括多行,如果对应的输入括号匹配,输出YES,否则输出NO

输入样例

()()()
((()))
())(
((()

输出样例  

YES
YES
NO
NO

代码展示 

#include<bits/stdc++.h>
#include<iostream>
#include<stack>
#include<string>
#include<cctype>
using namespace std;


int main(){
	string brackets;
	while(cin>>brackets){
		stack<char>check;
		for(int i=0;i<brackets.length();){
			if(check.empty()){
				check.push(brackets[i]);
				i++;
			}
			else if(!check.empty()&&check.top()=='('&&brackets[i]==')'){
				check.pop();
				i++;
			}
			else if(!check.empty()&&check.top()=='('&&brackets[i]=='('){
				check.push(brackets[i]);
				i++;
			}
			else{
				check.push(brackets[i]);
				i++;
			}
		}
		if(check.empty())  cout<<"YES"<<endl;
		else  cout<<"NO"<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值