floyd例题(求能确定几头奶牛的排名)

题目:

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题目大意:第一行给出两个数n,m,n代表奶牛的数量,m代表m场比赛,下面m行每行有两个整数a,b,代表本场比赛a能够击败b,(注:若a能击败b,b能击败c,则代表a能击败c)问最后能确定多少头奶牛的排名。

解决方法:通过使用floyd算法,将每两头奶牛的胜负关系确定,如果知道一头奶牛与其他所有奶牛的胜负关系,则可推出这头奶牛的排名。

#include<iostream>
#include<cstring>
using namespace std;

const int N=105;
int gx[N][N];
int n,m,ans;

void floyd()
{
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				if(gx[i][k]&&gx[k][j])
					gx[i][j]=1;
}

int main()
{
	cin>>n>>m;
	memset(gx,0,sizeof gx);
	int s,f;

	for(int i=1;i<=m;i++)
	{
		cin>>s>>f;
		gx[s][f]=1;
	}

	floyd();

	for(int i=1;i<=n;i++)
	{
		int cnt=0;
		for(int j=1;j<=n;j++)
			if(gx[i][j]||gx[j][i])
				cnt++;
		if(cnt==n-1)
			ans++;
	}

	cout<<ans<<endl;
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值