模拟栈相关练习

Acwing828模拟栈

实现一个栈,栈初始为空,支持四种操作:

  1. push x – 向栈顶插入一个数 x;
  2. pop – 从栈顶弹出一个数;
  3. empty – 判断栈是否为空;
  4. query – 查询栈顶元素。

现在要对栈进行 M 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 M,表示操作次数。

接下来 M行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 empty 和 query 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YES 或 NOquery 操作的查询结果为一个整数,表示栈顶元素的值。

数据范围

1≤M≤100000,
1≤x≤1e9
所有操作保证合法。

输入样例:
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty
输出样例:
5
5
YES
4
NO

AC代码:

#include<iostream>
#include<string>
using namespace std;

const int N=1e5+10;
int m,a[N],top;
string op;

int main()
{
    cin>>m;
    top=-1;
    while(m--)
    {
        cin>>op;
        if(op=="push")
        {
            int x;
            cin>>x;
            a[++top]=x; 
        }
        else if(op=="pop")
        {
            if(top!=-1)
                top--;
        }
        else if(op=="query")
        {
            cout<<a[top]<<endl;
        }
        else
        {
            if(top==-1)
                cout<<"NO"<<endl;
            else 
                cout<<"YES"<<endl;
        }
    }
}

Acwing830单调栈

给定一个长度为 N 的整数数列,输出每个数左边第一个比它小的数,如果不存在则输出 −1−1。

输入格式

第一行包含整数 N,表示数列长度。

第二行包含 N 个整数,表示整数数列。

输出格式

共一行,包含 N个整数,其中第 i个数表示第 i个数的左边第一个比它小的数,如果不存在则输出 −1−1。

数据范围

1≤N≤1e5
1≤数列中元素≤1e9

输入样例:
5
3 4 2 7 5
输出样例:
-1 3 -1 2 2

 AC代码1:

#include<iostream>
using namespace std;

const int N=1e5+10;
int n,top,stk[N],a[N];

int main()
{
    cin>>n;
    top=-1;
    for(int i=0;i<n;i++)
    {
        cin>>a[i];
        
        while(top!=-1&&stk[top]>=a[i])
        {
            --top;
        }
        if(top==-1)
            cout<<-1<<' ';
        else 
            cout<<stk[top]<<' ';
        stk[++top]=a[i];
    }
}

AC代码2:

#include<iostream>
#include<stack>
using namespace std;

const int N=1e5+10;
int n,a[N];
stack<int>stk;

int main()
{
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>a[i];
        
        while(!stk.empty()&&stk.top()>=a[i])
        {
            stk.pop();
        }
        if(stk.empty())
            cout<<-1<<' ';
        else 
            cout<<stk.top()<<' ';
        stk.push(a[i]);
    }
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值