紫书——安迪的第一个字典

题目:

输入一个文本,找出所有不同单词(连续的字母序列),按字典序从小到大输出,不区分大小写。

样例输入:

Adventure in Disneyland.

Two blonds were going to Disneyland when they came to a fork in the road.

The sign read: “Disneyland Left”.

So they went home.

样例输出:(只保留前五行)

a

adventure

blonds

came

disneyland

分析:

字符串问题:看到给出一个文本有空格和换行,可以考虑用stirngstream去掉空格,题目还要求按字典序输出不重复的单词,很明显set有这个功能,然后进行模拟即可。

里面还有一个用得很妙的地方就是如果字符串中不是英文字母,就用空格代替,这样再获取单词时就不会出错了

#include<set>
#include<sstream>
#include<string>
#include <iostream>
#include <algorithm>
using namespace std;
set<string>dict;
int main()
{
    string s;
    while (cin >> s) {
        for (int i = 0; i < s.size(); ++i) {
            if (isalpha(s[i])) {
                s[i] = tolower(s[i]);
            }
            else {
                s[i] = ' ';
            }
        }
        string buf;
        stringstream ss(s);
        while (ss >> buf) {
            dict.insert(buf);
        }
    }
    for (set<string>::iterator it = dict.begin(); it != dict.end(); ++it) {
        cout << *it << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值