【实验四 循环结构】7-1 sdut-C语言实验-A+B for Input-Output Practice (Ⅳ)

7-1 sdut-C语言实验-A+B for Input-Output Practice (Ⅳ)

分数 10

全屏浏览题目

切换布局

作者 马新娟

单位 山东理工大学

Your task is to Calculate a + b.

输入格式:

Your task is to Calculate a + b.

输出格式:

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例">样例">输入样例:

在这里给出一组输入。例如:

2
1 5
10 20

输出样例:

在这里给出相应的输出。例如:

6
30

 本题并不难,首先要求你输入循环的次数,然后将ab放入循环中控制输入和输出,可以用for和while做。

答案示例1(for) 

#include<stdio.h>
int main ()
{
    int n,a,b,i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d %d",&a,&b);
        printf("%d\n",a+b);
    }
    return 0;
}

答案示例2(while) 

#include<stdio.h>
int main ()
{
    int n,a,b,i=0;
    scanf("%d",&n);
    while(i<n)
    {
        scanf("%d %d",&a,&b);
        printf("%d\n",a+b);
        i++;
    }
    return 0;
}

答案示例3(while)这段代码更简单一些,可以少写一两句。

#include<stdio.h>
int main ()
{
    int n,a,b;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d %d",&a,&b);
        printf("%d\n",a+b);
    }
    return 0;
}

记得点赞哦!!!

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值