NYOJ - 数的长度

数的长度
时间限制:3000 ms | 内存限制:65535 KB
难度:1
描述
N!阶乘是一个非常大的数,大家都知道计算公式是N!=N*(N-1)······*2*1.现在你的任务是计算出N!的位数有多少(十进制)?

输入
首行输入n,表示有多少组测试数据(n<10)
随后n行每行输入一组测试数据 N( 0 < N < 1000000 )
输出
对于每个数N,输出N!的(十进制)位数。
样例输入
3
1
3
32000
样例输出
1
1

130271

代码:

#include<iostream>
 #include<cstdio>
 #include<cstring>
 #include<algorithm>
 #include<cmath>
 using namespace std;
 const int maxn=100000+5;
 int str[maxn];
 int main()
 {
     int t;
     scanf("%d",&t);
     while(t--)
     {
         int n;
         scanf("%d",&n);
         double s=0.0;
         if(n==0)
         {
             printf("1\n");
             continue;
         }
         else
         {
             while(n>0)
             {
                 s+=log10(n);
                 n--;
             }
         }
         printf("%d\n",(int)s + 1);
     }
     return 0;
 }

#include <stdio.h>
#include <math.h>
int main()
{
	int n,m,s;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&m);
		if(m == 1)
		{
			printf("1\n");
			continue;
		}
		s = (int)((log10(sqrt(4.0*acos(0.0)*m))+m*(log10(m)-log10(exp(1.0))))+1);
		printf("%d\n",s);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值