Sumsets+dp+求组合方式

32 篇文章 0 订阅
16 篇文章 0 订阅

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1027    Accepted Submission(s): 403


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6
 

Source
 

Recommend
teddy
 
解法一:完全背包
#include<iostream>
using namespace std;
int dp[1000003];
int main()
{
 int n;
 
 int i,j;
 int s[21];
 memset(dp,0,sizeof(dp));
 dp[0]=1;
 for(i=0;i<=20;i++)
 {
  int sum=1;
  for(j=0;j<i;j++)
   sum=sum*2;
  s[i]=sum;
 }
 for(i=0;i<20;i++)
  for(j=s[i];j<=1000000;j++)
  {
   dp[j]+=dp[j-s[i]];
   dp[j]=dp[j]%1000000000;
  }
  while(cin>>n){
   cout<<dp[n]<<endl;
  }
  return 0;
}
 
 

设a[n]为和为 n 的种类数;

根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:

1.n为奇数,a[n]=a[n-1]

2.n为偶数:

(1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];

(2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n-2];

所以总的种类数为:a[n]=a[n-2]+a[n/2];

 

#include<iostream>
using namespace std;
int a[1000000];
int main()
{
    int i,n;
    a[1]=1;
    a[2]=2;
    for(i=3;i<=1000000;i++)
    {
        if(i%2==0)
        {
            a[i]=a[i-2]+a[i/2];
            if(a[i]>999999999)
                a[i]%=1000000000;
        }
        else
            a[i]=a[i-1];
    }
    while(~scanf("%d",&n))
    {        
        printf("%d\n",a[n]);
    }
    return 0;
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值