How many

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 974    Accepted Submission(s): 377


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
  
  
4 0110 1100 1001 0011 4 1010 0101 1000 0001
 

Sample Output
  
  
1 2
 
先用最小表示法将字符串还原到以最小字典序循环的串,然后把它放到set中进行判重就可以了。。。
# include<iostream>
# include<stdio.h>
# include<string>
# include<string.h>
# include<set>
using namespace std;
int min(int i,int j)
{
	return i>j?j:i;
}

inline int getmin(string &s)
{
   int i=0,j=1,k=0;
   int len = s.length();
   while(i<len && j<len && k<len)
   {
       int t = s[(i+k)%len] - s[(j+k)%len];
       if(!t) k++;
       else
       {
           if(t>0) i = i+k+1;
           else j = j+k+1;
           if(i == j) j++;
           k = 0;
       }
   }
   return min(i,j);
}

int main()
{
   int n;
   string s,s1;
   while(~scanf("%d",&n))
   {
       int num = 0;
       set<string> set1;
       set<string>::iterator it;
       for(int i=0;i<n;++i)
       {
           cin>>s;
           int j = getmin(s);
           s1.assign(s,j,s.length()-j);
           if(j) s1.append(s,0,j);
           if(!set1.count(s1))
           {
               num++;
               set1.insert(s1);
           }
       }
       cout<<num<<endl;
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值