Simpsons’ Hidden Talents +KMP

Simpsons’ Hidden Talents

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 56   Accepted Submission(s) : 17
Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
  
  
clinton homer riemann marjorie
 

Sample Output
  
  
0 rie 3
/*
题目大意:给你两个字符串,要你求第一个字符串的前缀是第二个字符串的后缀
的最长序列是多少?
思路:用a[]去与b[]匹配,并取最大值(其中有控制j<=lena&&i==lenb)
j<=lena控制a[]完全被b[]包含,i==lena保证是b[]的后缀,刚开始没看清楚是后缀,
wa了n次

*/
#include<iostream>
#include<cstdio>
using namespace std ;
#define MAX 50005 
int next[MAX],m,n;
char a[MAX] , b[MAX] ;
void pre_next(int k )
{
	int i = 0 , j = -1 ;
	next[0] = - 1 ;
	while( i < k )
	{
		if( j == -1 || a[i] == a[j])
		{
			i++ ;
			j++ ;
			next[i] = j ;
		}
		else
			j = next[j] ;
	}
}

int  KMP()
{
	int max = 0 , k =0 ;
	int i = 0 , j = 0  ;
	int lenb= strlen(b);
	int lena=strlen(a);
	while( i <= lenb )
	{
		if(j== - 1 || a[j]==b[i]){
			i++;
			j++ ;
		}
		else
			j = next[j] ;
		if(max<j&&j<=lena&&i==lenb){  //取最大值
				max = j ;
		}
	
	}
	return max ;
}

int main(void)
{	
	while(scanf("%s",a)!=EOF)
	{
		scanf("%s",b);
		int lena =strlen(a) ;
		pre_next(lena) ;
		int k = KMP();
		if(k==0 )
			printf("0\n");
		else
		{
			a[k]='\0';
			printf("%s %d\n",a, k);
		}
	}
	return 0 ; 
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值