Connect the Cities + prime算法 + (超时)并查集

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6008    Accepted Submission(s): 1747


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
/*思路:最小生成树算法,将还存在的路费用置为0,需要维修的路费用置为C(这地方注意输入数据的重复性,要取最小的一个值)*/
#include<iostream>
#include<cstdio>
using namespace std ;
#define MAX 505
#define inf 1000000000
int s[MAX][MAX] , vi[MAX] , n;
/*void prime()  //用prime算法计算最小生成树距离(使用这种算法超时)
{
	int i , j , sum = 0 ;
	while(true){
		int min1 = inf , k =- 1;
		for( i = 1 ; i <= n ; i ++)
		{
			if(vi[i])
			{
				for( j = 1 ; j <= n ; j ++)
					if(!vi[j] && min1 > s[i][j])
					{
						k = j ;
						min1 = s[i][j] ;
					}
			}
		}
		if( k == - 1)
			break;
		vi[k] =  1;
		sum += min1 ;
	}
	int cnt = 0 ;
	for( i = 1  ; i <= n ; i ++)
		if(vi[i])
			cnt ++ ;
	if(cnt == n && sum < inf )
		//cout << sum << endl ;
		printf("%d\n",sum);
	else
		//cout << "-1" << endl ;
		printf("-1\n");
	return ;
}*/
void prime()
{
	int i,j,k,min,dist[MAX],sum=0;
	for(i=1;i<=n;i++)
		dist[i]=s[1][i];
	vi[1]=1;
	for(i=2;i<=n;i++)
	{
		min=inf;
		k=i;
		for(j=1;j<=n;j++)
			if(!vi[j]&&dist[j]<min)
			{
				min=dist[j];
				k=j;
			}
		sum=sum+min;
		if(sum>=inf)
			break;
		vi[k]=1;
		for(j=1;j<=n;j++)
			if(!vi[j]&&s[k][j]<dist[j])
				dist[j]=s[k][j];
	}
	if(sum>=inf)
		printf("-1\n");
	else
		printf("%d\n",sum);
}

int main(void)
{
	int t ;
	//cin>> t;
	scanf("%d",&t);
	while(t --)
	{
		int  m , k ;
	//	cin>> n >> m >> k ;
		scanf("%d %d %d",&n , &m , &k);
		int i , j , l ;
		memset( vi , 0 , sizeof(vi));
		for( i = 0 ; i < MAX ; i ++) //初始化各个点的距离,置为无穷大
			for( j = 0 ; j < MAX ; j ++){
				s[i][j] = s[j][i] = inf ;
				if( i == j )
					s[i][j] = s[j][i] = 0 ;
			}
			for( i = 0 ; i < m ; i ++)
			{
				int A , B , C ;
			//	cin >> A >> B >> C ;
				scanf("%d %d %d",&A,&B,&C);
				s[A][B] = s[B][A] = s[A][B] > C ? C : s[A][B] ; //避免重复输入,取最小值
			}
			for( i = 0 ; i < k ; i ++) //将还存在的路置为0,即最小花费为0
			{
				int  t ,a[MAX];
			//	cin >> t ;
				scanf("%d",&t);
				for( j = 0 ; j < t ; j ++)
				//	cin >> a[j] ;
				scanf("%d",&a[j]);
				for( j = 0 ; j < t ; j ++)
					for( l = j + 1 ; l < t ; l ++ )
						s[a[j]][a[l]] = s[a[l]][a[j]] = 0 ;
			}
			vi[1] = 1 ;//从标号为1的点,开始进行prime算法
			prime();
	}
	return 0 ;
}
 
/*思路:并查集(超时算法) */
#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAX 505
int father[MAX];

typedef struct node
{
	int a,b;
	int c;
}NODE;
NODE ca[150005];

bool cmp(NODE x,NODE y)
{
	if(x.c<y.c)
	{
		return 1;
	}
	return 0;
}

int findset(int x)
{
	return x!=father[x]?father[x]=findset(father[x]):x;
}

int kruskal(int m)
{
	int i,mincost=0,x,y;
	for(i=0;i<m;i++)
	{
		x=ca[i].a;
		y=ca[i].b;
		x=findset(x);
		y=findset(y);
		if(x!=y)
		{
			father[x]=y;
			mincost+=ca[i].c;
		}
	}
	return mincost;
}
int main()
{
	int n,m,k,i,mincost=0 , t ;
	scanf("%d",&t);
	while( t--)
	{
		scanf("%d %d %d",&m,&n,&k);
		for(i=0;i<n;i++)
		{
			scanf("%d %d %d",&ca[i].a,&ca[i].b,&ca[i].c);
		}
		int kk = i ;
		while(k--)
		{
			int t1 , a[MAX];
			scanf("%d",&t1);
			for( i = 0 ; i < t1 ; i ++ )
				scanf("%d",&a[i]);
			for( i = 0 ; i <t1 ; i ++)
				for( int j = i + 1; j < t1 ; j ++)
				{
					ca[kk].a = a[i] ;
					ca[kk].b = a[j] ;
					ca[kk++].c = 0 ;
				}
		}
		for(i=0;i<m;i++)
		{
			father[i]=i;
		}
		sort(ca,ca+kk,cmp);
		int l = 1 ;
		for( i = 1 ; i < kk ; i ++) //去掉重复的路,取最小值
		{
			if(ca[i].a == ca[i-1].a && ca[i].b == ca[i-1].b )
				continue ;
			ca[l].a = ca[i].a ;
			ca[l].b = ca[i].b ;
			ca[l++].c = ca[i].c ;
		}
		mincost=kruskal(l);
		int count=0;
		for(i=0;i<m;i++)
		{
			if(father[i]==i)
			{
				count++;
			}
		}
		if(count>1)
		{
			puts("?");
			
		}
		else
		{
			printf("%d\n",mincost);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值