Spring|ApplicationContext.xml|通配符的匹配很全面, 但无法找到元素 'aop:xxxx' 的声明

通配符的匹配很全面, 但无法找到元素 ‘xx:xxxx’ 的声明。
此类问题的根源是在于xml配置文件上,无法通过你给的地址找到版本。例如:

<beans xmlns="http://www.springframework.org/schema/beans"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
	xmlns:context="http://www.springframework.org/schema/context"
	xmlns:mvc="http://www.springframework.org/schema/mvc"
	xmlns:aop="http://www.springframework.org/schema/aop"
	xsi:schemaLocation="http://www.springframework.org/schema/mvc
	http://www.springframework.org/schema/mvc/spring-mvc-3.2.xsd              
	http://www.springframework.org/schema/beans              
	http://www.springframework.org/schema/beans/spring-beans-3.2.xsd              
	http://www.springframework.org/schema/aop 
	http://www.springframework.org/schema/aop/spring-aop-3.2.xsd             
	http://www.springframework.org/schema/context              
	http://www.springframework.org/schema/context/spring-context-3.2.xsd">

在这里插入图片描述
这些配置是通过网络进行下载的。

解决方法:修改为以下的代码

xsi:schemaLocation="http://www.springframework.org/schema/mvc
	http://www.springframework.org/schema/mvc/spring-mvc.xsd              
	http://www.springframework.org/schema/beans              
	http://www.springframework.org/schema/beans/spring-beans.xsd              
	http://www.springframework.org/schema/aop 
	http://www.springframework.org/schema/aop/spring-aop.xsd             
	http://www.springframework.org/schema/context              
	http://www.springframework.org/schema/context/spring-context.xsd"

就是不在限定版本号。

©️2020 CSDN 皮肤主题: 终极编程指南 设计师:CSDN官方博客 返回首页