HDU 2612

题目

Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

      4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
        

Sample Output

  66
88
66 

一、分析

使用两遍广搜

二、代码

代码如下(示例):

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
    int x,y,step;
};
int n,m;
char ch[209][209];
int dir[4][2]={0,-1,-1,0,0,1,1,0};
int vis[209][209];//标记数组
int num[209][209];//num记录到@的总时间
bool check(node a)
{
    return a.x>=0&&a.x<n&&a.y>=0&&a.y<m;
}
void bfs(int x,int y)
{
    node t,mat,s;
    int i;
    s.x=x;
    s.y=y;
    s.step=0;
    queue<node>q;
    vis[x][y]=1;
    q.push(s);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        for(i=0;i<4;i++)
        {
            mat.x=t.x+dir[i][0];
            mat.y=t.y+dir[i][1];
            mat.step=t.step+1;
            if(check(mat)&&ch[mat.x][mat.y]!='#'&&!vis[mat.x][mat.y])
            {
                vis[mat.x][mat.y]=1;
                q.push(mat);
                if(ch[mat.x][mat.y]=='@')
                {
                    //这里是+=,不是=,因为这点是@,记录的是两人到这的总时间
                    num[mat.x][mat.y]+=mat.step;
                }
            }
        }
    }
}
int main()
{
    int yx,yy,mx,my,i,j;
    while(scanf("%d%d",&n,&m)==2)
    {
        for(i=0;i<n;i++)
        {
            getchar();
            for(j=0;j<m;j++)
            {
                scanf("%c",&ch[i][j]);
                if(ch[i][j]=='Y')
                {
                    yx=i;yy=j;
                }
                else if(ch[i][j]=='M')
                {
                    mx=i;my=j;
                }
            }
        }
        memset(vis,0,sizeof(vis));
        memset(num,0,sizeof(num));
        bfs(yx,yy);
        memset(vis,0,sizeof(vis));
        bfs(mx,my);
        int ans=99999999;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(num[i][j]!=0&&ans>num[i][j])
                    ans=num[i][j];
            }
        }
        printf("%d\n",ans*11);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值