HDU 1072 Nightmare

15 篇文章 0 订阅
7 篇文章 0 订阅

题目

hduoj1072

Nightmare

Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius’ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius’ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1

Sample Output
4
-1
13

一、代码与分析

广搜
[1]
代码如下(示例):

/*
0:该区域是一堵墙,Ignatius不应该在上面行走。
1:该区域不包含任何东西,Ignatius可以在上面行走。
2:伊格内修斯的开始位置,伊格内修斯开始从这个位置逃跑。
3:迷宫的出口,伊格内修斯的目标位置。
4:该区域包含一个炸弹重置设备,伊格内修斯可以通过步行到这些区域来延迟爆炸时间。
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define MAX 99999
using namespace std;
struct Node
{
    int x,y;
    int time;
    int step;//当前走的步数
};

int dir[4][2] = {{0,1},{0,-1},{1,0},{-1,0}};
int n,m,minstep;
int map[10][10];
int sj[10][10];//记录到每个位置时剩余时间
//1.定义两个节点,定义队列q,步数初始化为0,时间初始化为6
//2.while循环开始广搜,读取顶部节点后弹出
//3.时间为0时continue,map为4时重置时间为6,
//4.map为3时,若步数比minstep小,就更新minstep,终止此次循环
//5.利用for循环从四个方向广搜,map不能为墙:0
void dfs(Node p)
{
    Node now,next;
    queue<Node>q;
    p.step=0;
    p.time=6;
    q.push(p);
    map[p.x][p.y]=0;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.time==0) continue;
        if(map[now.x][now.y]==4) now.time=6;
        if(map[now.x][now.y]==3)
        {
            if(now.step<minstep)
                minstep=now.step;
                continue;
        }
        for(int i=0;i<4;i++)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            next.time=now.time-1;
            next.step=now.step+1;
            if(map[next.x][next.y]!=0&&next.time>sj[next.x][next.y])
            {
                sj[next.x][next.y]=next.time;
                q.push(next);

            }
        }
    }
}
int main()
{
    int t,i,j;
    Node b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        memset(sj,0,sizeof(sj));
        minstep=MAX;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                cin>>map[i][j];
                if(map[i][j]==2)
                {
                    b.x=i;
                    b.y=j;
                }
            }
        }
        dfs(b);
        if(minstep==MAX)
        {
            printf("%d\n",-1);
        }
        else
        {
            printf("%d\n",minstep);
        }
    }
    return 0;
}

[2]

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define MAX 99999

using namespace std;
/*
0:该区域是一堵墙,Ignatius不应该在上面行走。
1:该区域不包含任何东西,Ignatius可以在上面行走。
2:伊格内修斯的开始位置,伊格内修斯开始从这个位置逃跑。
3:迷宫的出口,伊格内修斯的目标位置。
4:该区域包含一个炸弹重置设备,伊格内修斯可以通过步行到这些区域来延迟爆炸时间。
*/
int n,m;
int flag;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int map[10][10];
struct node
{
    int x,y,step,time;
};
int check(int x,int y)
{
    if(x>=0&&y>=0&&x<n&&y<m&&map[x][y]!=0)
        return 1;
    return 0;

}
void bfs(node p)
{

    queue<node> q;
    node now,next;
    p.step=0;
    p.time=6;
    q.push(p);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            next.step=now.step+1;
            next.time=now.time-1;
            //if(next.x>=0&&next.y>=0&&next.x<n&&next.y<m&&map[next.x][next.y]!=0&&next.time>0)
            if(check(next.x,next.y)&&next.time>0)
            {
                if(map[next.x][next.y]==3)
                {
                    printf("%d\n",next.step);
                    return ;
                }
                else if(map[next.x][next.y]==4)
                {
                    next.time=6;
                    map[next.x][next.y]=0;
                }
                q.push(next);
            }
        }
    }
    printf("-1\n");
    return ;
}
int main()
{
    int T;
    node p;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]==2)
                {
                    p.x=i;
                    p.y=j;
                }
            }
        }
        bfs(p);
    }
    return 0;
}

https://blog.csdn.net/acmman/article/details/38345509

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值