引用hellochart库遇到的坑

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wfskxj/article/details/80345882

1,在导入hellochart jar包后,在布局文件里引用lecho.lib.hellocharts.view.LineChartView后,运行时会一直报     Caused by: android.view.InflateException: Binary XML file line #0: Binary XML file line #0: Error inflating class lecho.lib.hellocharts.view.LineChartView

查到是因为lib里没导入v7的包

2,导入v7的包时必须注意v7包的版本不能比build.gradle里的依赖的版本高,不然会报

cann't find ..intermediates\incremental\mergeDebugResources\merged.dir\values-v28\values-的错

之后就可以正常用了

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭