hdu 1142 A Walk Through the Forest

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3450    Accepted Submission(s): 1269


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
    
    
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
    
    
2 4
 
import java.util.ArrayDeque;
import java.util.Arrays;
import java.util.Queue;
import java.util.Scanner;

/**
 *  @功能Function Description:    最短路径变形
 *  @开发环境Environment:         eclipse
 * 	@技术特点Technique:           
 *	@版本Version:				  Scanner
 *	@作者Author:                  follow your dreams
 *	@日期Date:                    20120809
 *	@备注Notes:                   题目大意:寻找一共有多少条符合题意的路。
 *								  能够从点A走到点B的要求是:点A到终点的最短路 > 点B到终点的最短路。 
 *                                也就是说:从终点出发,求每一个点的最短路,然后那些最短路的值记录起来,作为能否通过的判断条件。
 *                                最后用记忆化搜索来搜索出一共多少条符合要求的路。bfs是超时。
 *  @链接:                       http://acm.hdu.edu.cn/showproblem.php?pid=1142
 */

public class HD1142_2_20120821 {
	
	public static int arr[][];//地图
	
	public static int[] shortest;//当前点到终点的最短路径
	
	public static int[] value;
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int m, n;//m是编号,n是边的树木
		while(0 != (m=sc.nextInt())){
			n = sc.nextInt();
			arr = new int[m+1][m+1];
			shortest = new int[m+1];
			for(int i=1; i<=n; i++) {
				int x, y, value;
				x = sc.nextInt();
				y = sc.nextInt();
				value = sc.nextInt();
				arr[x][y] = value;
				arr[y][x] = value;
			}
			bellmanFord();
			value = new int[m+1];
			System.out.println(dfs(m+1, 1));
		}
	}
	
//	public static int bfs() {//超时(没办法记忆已经求过的值)
//		Queue<Integer> queue = new ArrayDeque<Integer>();
//		queue.add(1);
//		int count = 0;
//		int len = arr.length;
//		while(!queue.isEmpty()) {
//			int i = queue.poll();
//			if(i!=2) {
//				for(int j=1; j<len; j++) {
//					if(arr[i][j] != 0) {
//						if(shortest[i] > shortest[j]) {
//							queue.add(j);
//						}
//					}
//				}
//			} else {
//				count ++;
//			}
//		}
//		return count;
//	}
	
	public static int dfs(int len, int i) {//记忆搜索
		if(i == 2) {//找到终点就return 1
			return 1;
		}
		if(value[i] != 0) {//如果原来找到了就不用再次找了,就直接就return 找到的值
			return value[i];
		}
		for(int j=1; j<len; j++) {
			if(arr[i][j]!=0 && shortest[i]>shortest[j]){
				value[i] += dfs(len, j);
			}
		}
		return value[i];
	}
	
	/**
	 * 一个点到所有点的最短路径
	 * 贝尔曼-福特算法:求一个点到所有点的最短路径
	 */
	public static void bellmanFord() {                    
		Arrays.fill(shortest, Integer.MAX_VALUE);//将所有的距离都存成最大值
		int len = arr.length;
		Queue<Integer> queue = new ArrayDeque<Integer>();
		queue.add(2);//将终点进队
		shortest[2] = 0;//将终点的到终点的距离赋值为0
		while(!queue.isEmpty()) {//队列为空结束
			int x = queue.poll();//每次出队值
			for(int i=1; i<len; i++) {
				if(arr[x][i] != 0) {
					if(shortest[i] > shortest[x] + arr[x][i]) {//原来的值如果大于所求的值的话就将原来的值覆盖掉
						shortest[i] = shortest[x] + arr[x][i];
						if(!queue.contains(i)) {//如果当前的节点不在队列中,将其如队
							queue.add(i);
						}
					}
				}
			}
		}
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值