poj 1703 Find them, Catch them

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3450    Accepted Submission(s): 1269


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
    
    
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
    
    
2 4
 
 
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;


/**
 *  @功能Function Description:    并查集
 *  @开发环境Environment:         eclipse
 * 	@技术特点Technique:           看题,知道是并查集,但是怎么写呢?并查集要得是a与b相同才合并,现在是a与b不同。
								  关键就是一句话:敌人的敌人是朋友。
                                  我们对每个人x,都假设初始时他有一个敌人x+n,每次碰到D a b,就把a与b的敌人合并,b与a的敌人合并。
                                  当查询时:若find(a)== find(b):朋友
                                  若find(a)==find(b+n)||find(b)==find(a+n):敌人;
                                  都不是:无法确定。
 *	@版本Version:				  
 *	@日期Date:                    20120815
 *	@备注Notes:                   
 */

public class PK1703_3_20120815 {
	
	public static int[] father = new int[200005];
	
	public static void main(String[] args) throws IOException {
		StreamTokenizer st = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		st.nextToken();
		int countCase = (int)st.nval;
		int n, m;
		int x, y;
		String command;
		while(countCase-- !=0) {
			st.nextToken();
			n = (int)st.nval;//n个人
			st.nextToken();
			m = (int)st.nval;//m个消息序列
			makeSet(2*n);
			for(int i=0; i<m; i++) {
				st.nextToken();
				command = st.sval;//那种指令
				st.nextToken();
				x = (int)st.nval; 
				st.nextToken();
				y = (int)st.nval;
				if("D".equals(command)) {
					union(x, y+n);
					union(y, x+n);
				} else {
					if(n==2) {
						if(x==y) System.out.println("In the same gang.");
						else System.out.println("In different gangs.");
					} else {
						System.out.println(judge(x, y, n));
					}
				}
			}
		}
	}
	
	public static String judge(int x, int y, int n) {
		int fx = find(x);
		int fy = find(y);
		if(fx == fy) {//如果根相等的话,证明输入过(D x ~)和(D y ~) 
			return "In the same gang.";
		} else {
			if(fx==find(y+n) || fy==find(x+n)) {//输入过(x,y),或者(y,x),因此x和y不同帮派
				return "In different gangs.";
			} else {
				return "Not sure yet.";
			}
		}
	}
	
	public static void union(int x, int y) {
		x = find(x);
		y = find(y);
		if(x != y) {
			father[x] = y;
		}
	}
	
	public static void makeSet(int n) {
		for(int i=1; i<=n; i++) {
			father[i] = i;
		}
	}
	
	public static int find(int x) {
		if(x != father[x]) {
			father[x] = find(father[x]);
		}
		return father[x];
	}

}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值