hdu 3371 Connect the Cities

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4779    Accepted Submission(s): 1409


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
 

题目大意:

输入一个T,代表有总共有T组测试数据,接下来一行输入n,m,k,其中n(3<=n<=500)表示城市的个数,m(0<=m<=25000)表示可以选择桥的个数,k(0<=k<=100)表示已连接的分块个数。接着,输入m行可供选择的桥的参数p,q,r,表示该桥连接p和q需要花费c(0<=c<=1000)。最后输入k行,其中,每行的第一个代表(t),代表有t个已经互相连接在一起的城市,然后,就是t个该城市的代号(1~n)。问:连接所有的城市,所需要的最小花费?若无法连接,则输出-1。

 

思路:

1. prime算法

2.将已经存在的路径的长度设置成0.

3.将map[i][i]=-1,就是将自己到自己的路径(map[][]的对角线)设置成-1

 

注意:

1.在代码上有标注

2.不能用scanner,scanner超时,可以用StreamTokenizer

 

package hd;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
import java.util.Arrays;
/** 
 *  @功能Function Description:  prime算法
 *  @开发环境Environment:        eclipse 
 *  @技术特点Technique:            
 *  @算法                          
 *  @版本Version:               Scanner 
 *  @作者Author:                follow your dreams 
 *  @日期Date:                  20120830 
 *  @备注Notes:                 
 *  @链接:                      http://acm.hdu.edu.cn/showproblem.php?pid=3371
 */  
public class HD3371_1_20120830 {
	
	public static int map[][];

	public static void main(String[] args) throws IOException {
		//Scanner sc = new Scanner(System.in);
		StreamTokenizer st = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));//注意2:scanner超时
		st.nextToken();
		int count = (int)st.nval;
		int n, m, k;
		int a, b, value, t;
		while(count-- != 0) {
			st.nextToken();
			n = (int)st.nval;
			st.nextToken();
			m = (int)st.nval;
			st.nextToken();
			k = (int)st.nval;
			map = new int[n+1][n+1];
			initMap(n);
			for(int i=1; i<=m; i++) {
				st.nextToken();
				a = (int)st.nval;
				st.nextToken();
				b = (int)st.nval;
				st.nextToken();
				value = (int)st.nval;
				if(value < map[a][b]) {//注意1:后来输入的边的权值可能比原来输入的边的权值大 
					map[a][b] = map[b][a] = value;
				}
			}
			for(int i=1; i<=k; i++) {
				st.nextToken();
				t = (int)st.nval;
				st.nextToken();
				a = (int)st.nval;
				st.nextToken();
				b = (int)st.nval;
				map[a][b] = map[b][a] = 0;
				for(int j=1; j<=t-2; j++) {
					st.nextToken();
					b = (int)st.nval;
					map[a][b] = map[b][a] = 0;
				}
			}
			System.out.println(prime());
		}
	}
	
	public static int prime() {
		int len = map.length;
		boolean[] tag = new boolean[len];
		int[] low = new int[len];
		int sum = 0;
		for(int i=1; i<len; i++) {
			low[i] = map[1][i];
		}
		tag[1] = true;
		for(int i=1; i<len-1; i++) {
			int pos = 0;
			int min = Integer.MAX_VALUE;
			for(int j=1; j<len; j++) {
				if(!tag[j] && min > low[j]) {
					min = low[j];
					pos = j;
				}
			}
			tag[pos] = true;
			sum += min;
			if(min == Integer.MAX_VALUE) {
				return -1;
			}
			for(int j=1; j<len; j++) {
				if(!tag[j] && map[pos][j]!=-1 && low[j]>map[pos][j]) {
					low[j] = map[pos][j];
				}
			}
		}
		return sum;
	}
		
	public static void initMap(int n) {
		for(int i=1; i<=n; i++) {
			Arrays.fill(map[i], Integer.MAX_VALUE);
			map[i][i] = -1;
		}
	}

}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值