HOJ 最长上升子序列

本文介绍了如何使用C/C++编程解决10001号问题,即给定一个数字序列,找到其最长有序子序列的长度。主要展示了两种方法,包括C语言中的暴力搜索和动态规划,以及C++的优化版本,重点在于实现动态规划算法LIS。
摘要由CSDN通过智能技术生成

Longest Ordered Subsequence
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 4112, Accepted users: 3615
Problem 10001 : No special judgement
Problem description
A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
 
Input
The first line of input contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output must contain a single integer - the length of the longest ordered subsequence of the given sequence.
 
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4

 首先看C语言的解法,其他不说,最大的缺点就是超时。

#include <stdio.h>
int LIS(int s[],int n){
	int dp[n];
	int i,j;
	for(i=0;i<n;i++){
		dp[i]=1;
		for(j=0;j<i;j++){
			if(s[i]>s[j]){
				dp[i]= dp[i]<(dp[j]+1) ? (dp[j]+1):dp[i];
			}
		}
	}
	//打擂台法找最大值
	int maxlen=dp[0];
	for(i=0;i<n;i++){
		if(dp[i]>maxlen){
			maxlen=dp[i];
		}
	}
	return maxlen; 
}
int main(){
	int N;
	scanf("%d",&N);
	int seq[N];
	int i;
	for(i=0;i<N;i++){
		scanf("%d",&seq[i]);
	}
	int t=LIS(seq,N);
	printf("%d",t);
	return 0;
}

 借鉴一下互联网大佬的C++写法。如下:

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int dp[10050],h[10050];
int main(void)
{
	int n;
	while(~scanf("%d",&n))
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		scanf("%d",&h[i]);
		int sum=0,max;
		dp[1]=1;
		for(int i=1;i<=n;i++)
		{
			max=0;
			for(int j=1;j<=i;j++)
			{
				if(h[j]<h[i]&&max<dp[j])
				{
					max=dp[j];
				}	
				dp[i]=max+1;
			}		
		}
		for(int i=1;i<=n;i++)
		{
			if(dp[i]>sum)
			sum=dp[i];
		}
		printf("%d\n",sum);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值