hdu2767 Proving Equivalences[强连通分量]

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1792    Accepted Submission(s): 675


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
  
  
2 4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
 

Source
 

Recommend
lcy

题目大意:

给出一个有向图,问至少添加多少条边使图变成一个强连通分量。

解题思路:

先缩点,然后答案就是入度为0的点的个数和出度为0的点的个数中的最大的。但是尤其要注意缩点之后只有一个强连通分量的时候!第一次交的时候就忘了这个了!
#include<cstdio>
#include<cstring>
#include<iostream>
#include<stack>
using namespace std;
pair<int,int>side[50001];
stack<int>q;
int top,node[20001],low[20001],dfn[20001],in[20001],out[20001],t,cnt;
int n,m;
void dfs(int u){
	low[u]=dfn[u]=t++;
	q.push(u);
	int v;
	for(int i=node[u];i!=-1;i=side[i].second){
		v=side[i].first;
		if(!dfn[v])dfs(v);
		if(dfn[v]!=-1)low[u]=min(low[u],low[v]);
	}
	if(low[u]==dfn[u]){
		do{
			v=q.top();q.pop();
			dfn[v]=-1;
			low[v]=cnt;
		}while(v!=u);
		cnt++;
	}
}
void tarjan(){
	memset(dfn,0,sizeof(dfn));
	while(!q.empty())q.pop();
	cnt=0,t=1;
	for(int i=1;i<=n;i++){
		if(!dfn[i])dfs(i);
	}
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		top=0;
		memset(node,-1,sizeof(node));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			side[top]=make_pair(v,node[u]);
			node[u]=top++;
		}
		tarjan();
		for(int u=1;u<=n;u++){
			for(int i=node[u];i!=-1;i=side[i].second){
				int v=side[i].first;
				if(low[u]==low[v])continue;
				else{
					in[low[v]]++;
					out[low[u]]++;
				}
			}
		}
		int count_in=0,count_out=0;
		if(cnt==1){printf("0\n");continue;}
		for(int i=0;i<cnt;i++){
			if(in[i]==0)count_in++;
			if(out[i]==0)count_out++;
		}
		printf("%d\n",max(count_in,count_out));
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值