2011百校联动“菜鸟杯”程序设计公开赛_BBacon's Cipher

9 篇文章 0 订阅
4 篇文章 0 订阅

https://en.wikipedia.org/wiki/Bacon%27s_cipher    维基百科上的培根的密码

Bacon's Cipher

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1822    Accepted Submission(s): 1003


Problem Description
Bacon's cipher or the Baconian cipher is a method of steganography (a method of hiding a secret message as opposed to a true cipher) devised by Francis Bacon. A message is concealed in the presentation of text, rather than its content. 
As we all know, each letter has its position in the alphabet, ‘A’ is 0, ‘B’ is 1, ‘C’ is 2…and so on. And each number can be represented in binary code, for example, 2 is ‘10’ in binary system. Then we expand the binary code to five digits by adding leading zeros, then 10 becomes 00010. Now we can use this number to encode. To simplify the question, we define the rules as below:
0 corresponds to a random uppercase letter and 1 corresponds to a random number, so after encoding, 00010 ( ‘C’ ) is transformed to ABC1D or JUG9N. 
To decode, do the opposite way around.
 

Input
The first line contains a positive number l, represents the length of the encoded string. L<=10000 and can be divided by 5. The second line is the encoded string.
 

Output
The original string.
 

Sample Input
 
 
35 ON1E2H5Q39AK2TGIC9ERT39B2P423L8B20D
 

Sample Output
 
 
FLEENOW
 

Author
BNU
 

Source


#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int n,i,str2[5],temp;
	char str,str3[2001];
	while(scanf("%d",&n)!=EOF){
		getchar();
		for(i=0;i<n/5;i++){
			temp=0;
			for(int j=0;j<5;j++){
				scanf("%c",&str);
				if(str>='A'&&str<='Z')str2[j]=0;
				else if(str>='0'&&str<='9')str2[j]=1;
					temp=temp+str2[j]*pow(2,4-j);
			}
			str3[i]='A'+temp;
		}
		str3[i]='\0';
		printf("%s\n",str3);
		
	}
return 0;
 
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值