F - Robot Motion

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 
Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)
题目大致看懂了,想起之前老师教过深搜的,就用了,但是不知道怎么下手。百度哪些奇奇怪怪的,最后还是自己写了。一开始是直接用三个数组,一个存地图一个存步数一个判断是否走过,但是超时了。最后解决了。开心
#include<iostream>
using namespace std;
char map[300][300];
int step[300][300]={0};
int r[4]={0,-1,0,1};
int c[4]={1,0,-1,0};
int row,col,n,m,st;
void dfs();
void output();
void out(int x,int y);
int judge(int x,int y);
int main()
{
 int i,j;
 while(1)
 {
  cin>>n>>m>>col;
  row=1;
  st=0;
  if(n==0&&m==0)
  {
   break;
  }
  for(i=1;i<=n;i++)
  {
   for(j=1;j<=m;j++)
   {
    cin>>map[i][j];
   }
  }
  dfs();
 }
    return 0; 
}
void dfs()
{
 int j;
 if(row<1||col<1||row>n||col>m)
 {
  output();
 }
 else if(map[row][col]=='0') //为零则说明有循环部分。 
 {
  out(row,col);
 }
 else 
 {
  j=judge(row,col);
  map[row][col]='0';//最关键的部分,走过后就换为0,可以代替判断是否走过的数组。 
  step[row][col]=st;
  st+=1;
  row+=r[j],col+=c[j];
  dfs();
 }
}
int judge(int x,int y)
{
 if(map[x][y]=='E')
 {
  return 0;
 }
 if(map[x][y]=='N')
 {
  return 1;
 }
 if(map[x][y]=='W')
 {
  return 2;
 }
 if(map[x][y]=='S')
 {
  return 3;
 }
}
void output()
{
 cout<<st<<" step(s) to exit"<<endl;
}
void out(int x,int y)
{
 cout<<step[x][y]<<" step(s) before a loop of "<<(st-step[x][y])<<" step(s)"<<endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值