(2)S - 贪心

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
Sample Output
80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意:
超市里有n个产品要卖,每个产品都有一个截至时间dx(从开始卖时算起),只有在这个截至时间之前才能卖出并且获得率润dy。
有多个产品,所有可以有不同的卖出顺序,每卖一个产品要占用1个单位的时间,问最多能卖出多少利润。
思路:按利润从大到小排序,然后从最大利润开始,将时间加入查并集,如果这天要被占用,就将a[temp]=temp-1,表示日期和temp相同的,最晚只能从temp-1买,虽然能简化算法,但是专门找了一下查并集,也不是很懂。能懂的是将当天标记下来,被占用了就不能再用了
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int find(int x);
struct node
{
 int pi;
 int di;
}m[10010];
int a[10010];
bool cmp(node x,node y)//按利润从大到小排序
{
 return x.pi>y.pi;
}
int main()
{
 int n,i,temp;
 while(cin>>n)
 {
  
  int sum=0;
  for(i=0;i<10010;i++)
  {
   a[i]=i;
  }
  for(i=0;i<n;i++)
  {
   cin>>m[i].pi>>m[i].di;
  }
  sort(m,m+n,cmp);
  for(i=0;i<n;i++)
  {
   temp=find(m[i].di);
   if(temp>0)
   {
    a[temp]=temp-1;
    sum+=m[i].pi;
   }
  }
  cout<<sum<<endl;
 }
}
int find(int x)
{
 return a[x]==x?x:(a[x]=find(a[x]));//如果a[x]==x,就返回x,否则返回a[x];
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值