Find Q
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)Total Submission(s): 319 Accepted Submission(s): 181
Problem Description
Byteasar is addicted to the English letter ‘q’. Now he comes across a string
S
consisting of lowercase English letters.
He wants to find all the continous substrings of S , which only contain the letter ‘q’. But this string is really really long, so could you please write a program to help him?
He wants to find all the continous substrings of S , which only contain the letter ‘q’. But this string is really really long, so could you please write a program to help him?
Input
The first line of the input contains an integer
T(1≤T≤10)
, denoting the number of test cases.
In each test case, there is a string S , it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000 .
In each test case, there is a string S , it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000 .
Output
For each test case, print a line with an integer, denoting the number of continous substrings of
S
, which only contain the letter ‘q’.
Sample Input
2 qoder quailtyqqq
Sample Output
1 7
Source
问题描述
Byteasar迷恋上了'q'这个字母。
在他眼前有一个小写字母组成的字符串$S$,他想找出$S$的所有仅包含字母'q'的连续子串。但是这个字符串实在是太长了,你能写个程序帮助他吗?
输入描述
输入的第一行包含一个正整数$T(1\leq T\leq10)$,表示测试数据的组数。
对于每组数据,包含一行一个小写字母组成字符串$S$,保证$S$的长度不超过$100000$。
输出描述
对于每组数据,输出一行一个整数,即仅包含字母'q'的连续子串的个数。
解题思路:求只包含q的子串,可以利用规律sum[i]=sum[i-1]+I,把1,3,6,10...存在数组中。最需要注意的地方是数据范围,题中数组sum,总数ass都应该用longlong类型,不然就WA(多次受苦)...
#include<cstdio>
#include<cstring>
#include<iostream>
#define N 100005
using namespace std;
int main()
{
int i,t;
long long sum[N];
char s[N];
sum[1]=1;
for(i=2;i<=N;i++)
sum[i]=sum[i-1]+i;
scanf("%d",&t);
while(t--)
{
int cnt=0,len;
long long ass=0;
scanf("%s",s+1);
len=strlen(s+1);
for(i=1;i<=len+1;i++)
{
if(s[i]=='q') cnt++;
else
{
ass=ass+sum[cnt];
cnt=0;
}
}
printf("%lld\n",ass);
}
return 0;
}