pat甲级1007 Maximum Subsequence Sum (动态规划)

4 篇文章 0 订阅

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解题思路

简单的线形dp,数据很水,直接模拟也能过。设dp[i]表示[l, i](l <= i,i确定,l为变量)的最大值,可以推出状态转移方程dp[i]=max(dp[i - 1] + a[i], a[i])。 然后最大字段和就是max(dp[i])。如果最大值小于0,就输出0 a[1] a[k](存入时下标从1到k)。否则输出最大字段和以及其子段最左和最右的元素值(注意是元素值,不是下标,博主看错了用了好几种方法写到自闭)。假设最dp[x]最大,那从a[x]往左累加,和等于dp[x]的下标最小值就是最左边了。

代码如下

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
int a[100005];
int dp[100005];
int main()
{
	int k;
	while(cin >> k){
		memset(dp, 0, sizeof(dp));
		memset(a, 0, sizeof(a));
		for(int i = 1; i <= k; i ++){
			cin >> a[i];
		}
		for(int i = 1; i <= k; i ++)
			dp[i] = max(dp[i - 1] + a[i], a[i]);
		int maxx = -1;
		int r = 1;
		for(int i = 1; i <= k; i ++){
			if(dp[i] > maxx){
				maxx = dp[i];
				r = i;
			}		
		}
		if(maxx < 0){
			cout << 0 << " " << a[1] << " " << a[k] << endl;
			continue;
		}
		int sum = 0;
		int l;
		for(int i = r; i >= 1; i --){
			sum += a[i];
			if(sum == maxx)
				l = i;        //题目要求i,j最小如果是0 0 1 2这种就不能在1的位置break了,虽然题目没卡这个 
		}
		cout << maxx << " " << a[l] << " " << a[r] << endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值