hdu6299 Balanced Sequence(贪心+括号匹配)

1 篇文章 0 订阅

Balanced Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7092    Accepted Submission(s): 1862


 

Problem Description

Chiaki has n strings s1,s2,…,sn consisting of '(' and ')'. A string of this type is said to be balanced:

+ if it is the empty string
+ if A and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.

Chiaki can reorder the strings and then concatenate them get a new string t. Let f(t) be the length of the longest balanced subsequence (not necessary continuous) of t. Chiaki would like to know the maximum value of f(t) for all possible t.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤105) -- the number of strings.
Each of the next n lines contains a string si (1≤|si|≤105) consisting of `(' and `)'.
It is guaranteed that the sum of all |si| does not exceeds 5×106.

 

 

Output

For each test case, output an integer denoting the answer.

 

 

Sample Input

 

2 1 )()(()( 2 ) )(

 

 

Sample Output

 

4 2

 

 

Source

2018 Multi-University Training Contest 1

解题思路

这题就是求最多可以匹配多少括号数*2

贪心的思路是看了各路大佬的题解。

先匹配各个字符串,把匹配到的括号去掉并把个数加到答案里。去掉之后,每个字符串剩下的就是左边的一串‘)’和右边的一串‘(’。 记录每个字符串剩下的左边的数量和右边的数量(都可能为0)。然后排序。排序方式是:

先分为两组,‘(’数量大于‘)’数量的,以及‘(’数量小于‘)’数量的,前者在前面。

对于‘(’大于‘)’的字符串,按照‘)’的数量从小到大排序。

对于‘(’小于‘)’的字符串,按照‘(’的数量从大到小排序。

然后对排好序的字符串进行匹配,计算最后答案。

代码如下

#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <stack>
#include <cstdio>
#define maxn 100005
using namespace std;
struct T{
    int l, r;
    T(int l , int r): l(l), r(r){    }
};
vector<T> vec;
bool cmp(T& a, T& b)
{
    if (a.r >= a.l && b.r >= b.l) 
		return a.l < b.l;
    else if (a.r >= a.l)
		return true;
    else if (b.r >= b.l) 
		return false;
    else return 
		a.r > b.r;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t --){
        int n;
        scanf("%d%*c", &n);
        int ans = 0;
        for(int i = 1; i <= n; i ++){
            int l, r;
            l = r = 0;
            stack<char> sta;
            char ch;
            while((ch = getchar()) != '\n'){
                if(ch == ')'){
                    if(sta.empty())
                        l ++;
                    else {
                        sta.pop();
                        ans += 2;
                    }            
                }
                else if(ch == '(')    
                    sta.push(ch);
            }
            r = sta.size();
            vec.push_back(T(l, r));
        }
        sort(vec.begin(), vec.end(), cmp);    
        stack<char> sta;
        for(int i = 0; i < vec.size(); i ++){
            for(int j = 0; j < vec[i].l; j ++){
                if(!sta.empty()){
                    ans += 2;
                    sta.pop();
                }
            }
            for(int j = 0; j < vec[i].r; j ++){
                sta.push('(');
            }
        }
        printf("%d\n", ans);
        vec.clear();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值