Reward(HDOJ-2647)

Problem Description

Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output

For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

题意:

给出n个工人的m条工资对比关系,工人的最低工资是888。

思路:

很明显,只要拓扑排序一遍,得出每个工人的工资高低关系,然后高的人比低的人高1元,用res记录每个人的工资,如果最后统计出的人数小于n说明无法排序,输出-1。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <list>
#include <cmath>
#include <algorithm>
#define MST(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long ll;
const int MAXN = 10000 + 10;
int n, m;
vector <int> g[MAXN];
int res[MAXN], dgree[MAXN], ans;
void init() {
    for (int i = 1; i <= n; i++) g[i].clear();
    MST(res, 0);
    MST(dgree, 0);
    ans = 0;
}
bool topo() {
    queue <int> q;
    int pos = 0;
    for (int i = 1; i <= n; i++)
        if (!dgree[i]) {
            q.push(i);
            res[i] = 888;
            pos++;
        }
    while (!q.empty()) {
        int u = q.front();
        q.pop();
        ans += res[u];
        for (int i = 0; i < g[u].size(); i++) {
            if (--dgree[g[u][i]] == 0) {
                res[g[u][i]] = res[u] + 1;
                pos++;
                q.push(g[u][i]);
            }
        }
    }
    if (pos < n) return false;
    return true;
}
int main() {
    ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
    while (cin >> n >> m) {
        init();
        while (m--) {
            int x, y;
            cin >> x >> y;
            g[y].push_back(x);
            dgree[x]++;
        }
        if (!topo()) cout << "-1" << endl;
        else cout << ans << endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值