1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1​​ a​N​1​​ ​ N​2​​ a​N​2​​ … N​K​​ a​N​K
where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​ <⋯<N2 <N​1​​ ≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

解题思路
1.0≤N​K​​ <⋯<N2 <N​1​​ ≤1000.故设定数组容量为1001个
2.值为0的不显示
3.末尾不可以有多余的空格。
附代码:


#include <iostream>
#include <cstdio>
#include <cmath>
int main() {
    double array[1001];
    bool flag[1001];
    memset(array,0, sizeof(array));
    memset(flag,0, sizeof(flag));
    double temp = 0.0;
    //每一行输入数量
    int k,c=0;
    //输入两行
    int line = 2, curIndex = 0, maxIndex = -1;

    while (line--) {
        scanf("%d", &k);
        while (k--) {
            scanf("%d%lf", &curIndex, &temp);
            array[curIndex] += temp;
            //标记当前的序号为真
            if (!flag[curIndex]){
                flag[curIndex]= true;
                c++;
            }
            if(abs(array[curIndex])<1E-6){
                flag[curIndex]= false;
                c--;
            }
            if (maxIndex < curIndex) {
                maxIndex = curIndex;
            }
        }
    }

    //输出
    printf("%d", c);
    for (int i = maxIndex; i >-1 ; i--) {
        if (flag[i]){
            printf(" %d %.1f",i,array[i]);
        }
    }
}

这里对memset对使用稍稍进行解释:
函数原型
extern void *memset(void *buffer, int c, int count)
buffer:为指针或是数组,
c,赋值给buffer成员对值
count,则是buffer的长度
Memset 用来对一段内存空间全部设置为某个字符,一般用在对定义的字符串进行初始化为‘ ’或‘/0’;超好用的。
天天如此,天天快乐

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值