1071 Speech Patterns(字符串处理)

1071 Speech Patterns (25 分)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:
Can1: "Can a can can a can?  It can!"
Sample Output:
can 5
分析

此题考查字符串处理,遍历字符串,当遇到空格或者非数字字母的字符时,tmp即形成了一个符合要求的word。第一次提交时,测试点2(从0开始)没通过,读题不仔细,先入为主的判断以空格为分隔符,仔细检查发现,分隔符不仅可以是空格还可以是非数字字母的字符,测试点2考查的是这个。

#include <iostream>
#include <map>
#include <cctype>
using namespace std;
map<string,int> mp;
int main(){
	string ans;
	getline(cin,ans);
	string tmp;
	for(int i=0;i<(int)ans.size();i++){
		if(tmp!=""&&(ans[i]==' ' || (isalpha(ans[i])==0 && isdigit(ans[i])==0))){
			mp[tmp]++;
			tmp.clear();
		}else if(isalpha(ans[i]) || isdigit(ans[i])){
			tmp.push_back(tolower(ans[i]));
		}
	}
	if(tmp!="")mp[tmp]++;
	int max_cnt=-1;
	string max_str,tmp_str;
	bool first=true;
	for(auto it: mp){
		if(first){
			first=false;
			tmp_str=it.first;
		}else{
			if(tmp_str>it.first) tmp_str=it.first;
		}
		if(it.second>max_cnt){
			max_cnt=it.second;
			max_str=it.first;
		}
	}
	if(max_cnt>1) cout<<max_str<<" "<<max_cnt;
	else cout<<tmp_str<<" 1";
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值