The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
- Every candidate can place exactly one poster on the wall.
- All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
- The wall is divided into segments and the width of each segment is one byte.
- Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.
The picture below illustrates the case of the sample input.
Sample Input
1 5 1 4 2 6 8 10 3 4 7 10
Sample Output
4
题意:给你一个n,表示有n张海报,所有海报高度相等,给你每个海报要贴的位置,问你最后能看见几张海报。
思路:l,r都很大,但是n最多只有10000,因此我们可以进行离散化处理,简单的区间更新,第i个海报把所占区间染为i色,最后统计有几种颜色就能看见几张海报。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=2e5+100;
struct Node{
int l;
int r;
}a[maxn*4];
struct node{
int l;
int r;
int laz;
int sum;
}tree[maxn*4];
int book[maxn*4],b[maxn*4],res;
void build(int l,int r,int cur)
{
tree[cur].l=l;
tree[cur].r=r;
tree[cur].laz=-1;
tree[cur].sum=0;
if(l==r) return ;
int m=(l+r)>>1;
build(l,m,cur<<1);
build(m+1,r,cur<<1|1);
}
void pushdown(int cur)
{
if(tree[cur].laz!=-1)
{
tree[cur<<1].sum=tree[cur].laz;
tree[cur<<1].laz=tree[cur].laz;
tree[cur<<1|1].sum=tree[cur].laz;
tree[cur<<1|1].laz=tree[cur].laz;
tree[cur].laz=-1;
}
}
void update(int L,int R,int val,int cur)
{
if(L<=tree[cur].l&&tree[cur].r<=R)
{
tree[cur].laz=val;
tree[cur].sum=val;
return ;
}
pushdown(cur);
int m=(tree[cur].l+tree[cur].r)>>1;
if(L<=m) update(L,R,val,cur<<1);
if(R>m) update(L,R,val,cur<<1|1);
}
void query(int cur)
{
if(!book[tree[cur].sum]&&tree[cur].l==tree[cur].r)
{
book[tree[cur].sum]=1;
res++;
return ;
}
if(tree[cur].l==tree[cur].r) return ;
pushdown(cur);
query(cur<<1);
query(cur<<1|1);
return ;
}
int main()
{
int n,t,cnt;
scanf("%d",&t);
while(t--)
{
res=0;cnt=0;
memset(book,0,sizeof(book));
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i].l,&a[i].r);
b[++cnt]=a[i].l;
b[++cnt]=a[i].r;
}
sort(b+1,b+1+cnt);
cnt=unique(b+1,b+1+cnt)-(b+1);
build(1,cnt,1);
for(int i=1;i<=n;i++)
{
int x=lower_bound(b+1,b+1+cnt,a[i].l)-b;
int y=lower_bound(b+1,b+1+cnt,a[i].r)-b;
update(x,y,i,1);
}
query(1);
printf("%d\n",res);
}
return 0;
}