POJ 1562 Oil Deposits

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13490 Accepted: 7334

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source



解题思路:

入门的DFS求解联通块问题,只要从图中任意一个@开始搜索就行了,对于每个走完的@,我们将其改为*,这样一直下去,总共进行了几次大的dfs,就说明有几个联通块了,什么是大的dfs呢,大的dfs就是我们说的每次从@走,走到周围(8个方向)没有@的时候。。。。在看不懂的话,就去画个图看看吧。

开始做的时候把grid的类型写成了int,改了20分钟,,,终于查出来了~~~QAQ。千万不要写错了。


代码:

# include<cstdio>
# include<iostream>

using namespace std;

# define MAX 101

char grid[MAX][MAX];
int m,n;

int next[8][2] = { {-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1} };

void dfs( int x,int y )
{
    grid[x][y] = '*';

    for ( int i = 0;i < 8;i++ )
    {
        int n_x = x+next[i][0];
        int n_y = y+next[i][1];

        if ( n_x<0||n_y<0||n_x>=m||n_y>=n )
            continue;
        if ( grid[n_x][n_y]=='@' )
            dfs(n_x,n_y);

    }
    return;
}


int main(void)
{
    int cnt;
    while ( cin>>m>>n )
    {
        if ( m==0 )
            break;

        for ( int i = 0;i < m;i++ )
        {
            scanf("%s",grid[i]);
        }

        cnt = 0;
        for ( int i = 0;i < m;i++ )
        {
            for ( int j = 0;j < n;j++ )
            {
                if ( grid[i][j]=='@' )
                {
                    dfs(i,j);
                    cnt++;
                }
            }
        }

        cout<<cnt<<endl;

    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值