挑战2.1 Backward Digit Sums(POJ 3187)

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4764 Accepted: 2736

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.


题目大意:

题目说的是,给一个n,然后一个sum,从1-n这n个数字,通过类似于杨辉三角那样的相加得到sum,最后输出原数列的字典序最小的排序。


解题思路:

这题其实没有搜索就能出来了,只要以此枚举1-n的所有排列的情况,从1,2,3,,,n开始,通过next_permutation函数,这个函数的返回值是一个bool类型的变量,

他返回的是比当前这个排列大的一个排列(这个大肯定是通过比较字典序而得到的).然后,不断地通过寻找最终找到这个序列就可以输出了。


代码:

# include<cstdio>
# include<iostream>
# include<algorithm>

using namespace std;

# define MAX 12

int a[MAX];
int b[MAX];
int n,m;

void output()
{
    for ( int i = 0;i < n;i++ )
        cout<<a[i]<<" ";
    cout<<endl;
}

int cal ()
{
    for ( int i = 0;i < n;i++ )
        b[i] = a[i];

    for ( int num = n;num > 0;num-- )
    {
        for ( int i = 0;i < num-1;i++ )
        {
            b[i]+=b[i+1];
        }
    }
    if ( b[0]==m )
        return 1;
    else
        return 0;

}

void solve()
{

    if ( cal() )
    {
        output();
        return;
    }
    while ( next_permutation(a,a+n) )
    {
        if ( cal() )
        {
            output();
            break;
        }
    }
    return;

}

int main(void)
{
    while ( cin>>n>>m )
    {
        for ( int i = 0;i < n;i++ )
        {
            a[i] = i+1;
        }

        solve();
    }


    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值