20140920 【 线段树 — 区间覆盖,区间查询 】 2014 ACM/ICPC Asia Regional Guangzhou Online--A Corrupt Mayor's Perfor

14 篇文章 0 订阅
9 篇文章 0 订阅

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests

A Corrupt Mayor's Performance Art

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others)
Total Submission(s): 58    Accepted Submission(s): 20


Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary's idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?
 

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000) 

Then M lines follow, each representing an operation. There are two kinds of operations, as described below: 

1) P a b c 
a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b
a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.
 

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.
 

Sample Input
      
      
5 10 P 1 2 3 P 2 3 4 Q 2 3 Q 1 3 P 3 5 4 P 1 2 7 Q 1 3 Q 3 4 P 5 5 8 Q 1 5 0 0
 

Sample Output
      
      
4 3 4 4 7 4 4 7 8
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5031  5030  5029  5028  5027 
 

Statistic |  Submit |  Discuss |  Note
Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2014 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.003776(s) query 6, Server time : 2014-09-20 17:44:12, Gzip disabled












#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>
#include <stack>
#include <list>
#include <iterator>
using namespace std;
#define LL long long
#define MAXN 1000100
int n, m;
int sum[MAXN<<4], sign[MAXN<<4];

void push_up(int rt){
    sum[rt] = sum[rt<<1] | sum[rt<<1|1];
}

void push_down(int rt){
    if( sign[rt] ){
        sign[rt<<1] = sign[rt];
        sign[rt<<1|1] = sign[rt];
        sum[rt<<1] = sign[rt];
        sum[rt<<1|1] = sign[rt];
        sign[rt] = 0;
    }
}

void build(int rt, int l, int r){
    sum[rt] = 1<<2;
    sign[rt] = 0;
    if( l==r )  return ;
    int mid = (l+r)>>1;
    build(rt<<1, l, mid);
    build(rt<<1|1, mid+1, r);
}

void updata(int rt, int l, int r, int x, int y, int p){
    if( x<=l && r<=y ){
        sum[rt] = p;
        sign[rt] = p;
        return ;
    }
    push_down(rt);
    int mid = (l+r)>>1;
    if( x<=mid )    updata(rt<<1, l, mid, x, y, p);
    if( mid< y )    updata(rt<<1|1, mid+1, r, x, y, p);
    push_up(rt);
}

int query(int rt, int l, int r, int x, int y){
    if( x<=l && r<=y )  return sum[rt];
    push_down(rt);
    int mid = (l+r)>>1;
    int r1=0, r2=0;
    if( x<=mid )    r1 = query(rt<<1, l, mid, x, y);
    if( mid< y )    r2 = query(rt<<1|1, mid+1, r, x, y);
    return (r1|r2);
}

int main(){     
    while( EOF != scanf("%d %d\n", &n, &m) ){
        if( !n && !m )  break;
        build(1, 1, n);
        char op;
        int x, y, p;
        while( m-- ){
            scanf("%c %d %d", &op, &x, &y);
            if( op=='P' ){
                scanf("%d\n", &p);
                updata(1, 1, n, x, y, 1<<p );
            }
            else{
                scanf("\n");
                int ans = query(1, 1, n, x, y);
                int flag = 0;
                for(int i=1; i<=30; i++){
                    if( ans&(1<<i) ){
                        if(!flag)    printf("%d", i);
                        else         printf(" %d", i);
                        flag = 1;
                    }
                }
                printf("\n");
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值