hdu 1097

A hard puzzle

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b’s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input
There are mutiple test cases. Each test cases consists of two numbers a and b

Output
For each test case, you should output the a^b’s last digit number.

Sample Input
7 66
8 800

Sample Output
9
6

题意:给出a,b两个数,输出a^b结果的最后一位数?(水题,虽简单,但要细心)

0-9阶乘规律:
0: 0
1: 1
2: 2 4 8 6
3: 3 9 7 1
4: 4 6
5: 5
6: 6
7: 7 9 3 1
8: 8 4 2 6
9: 9 1

import java.util.Scanner;

public class Main {
    static int[][] num = new int[10][10];
    static {
        //数字规律存储num
        for(int i=0;i<=9;i++){
            for(int j=0;j<=9;j++){
                 if(j==0){
                     num[i][j] = 1;continue;
                 }
                 int k = i*num[i][j-1]%10;
                 if(k == num[i][1]) break;
                 num[i][j] = k;
            }
        }
    }
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int a,b;
        while(in.hasNext()){
            a = in.nextInt();
            b = in.nextInt();
            a %= 10;
            if(a == 0){
                System.out.println(0);
            }else{
                int length = 0;
                for(int i=1;num[a][i]!=0;i++)
                        length++;
                int res = b%length;
                if(res==0){
                    System.out.println(num[a][length]);
                }else{
                    System.out.println(num[a][res]);
                }
            }
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值