Hdu 1062

Text Reverse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29094 Accepted Submission(s): 11433

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

题解:字符串反串,可以运用栈原理。

import java.util.Scanner;

public class Main {
    public static String revert(String s){
        String res = "";
        char[] s1 = s.toCharArray();
        for(int i=s1.length-1;i>=0;i--){
            res+=s1[i];
        }
//      System.out.println(res);
        return res;
    }
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int N = in.nextInt();
        in.nextLine();
        while(N-- > 0){
            String str = in.nextLine();
//          System.out.println(str.length());
            //字符串处理
            String[]strs = str.split(" ");
            String res = "";
//          System.out.println("length"+strs.length);
            for(int i=0;i<strs.length;i++){
                if(i==strs.length-1)
                    res += revert(strs[i]);
                else
                    res += revert(strs[i]) + " ";
            }
            if(str.endsWith(" ")) res += " ";//Java代码需要考虑这种情况,不然提交PE。
            //PE后反思了一下发现还是自己写的方法靠谱一些,处理出的东西不是杂七杂八的
            System.out.println(res);
        }

    }

}

这是我自己没用Java库提供的方法处理字符串,居然简洁的不得了,只有20多行代码,啊哈哈,而且一次AC

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int N = in.nextInt();
        in.nextLine();
        while(N-- > 0){
            String str = in.nextLine();
            //字符串处理
            String res = "";
            String res1 = "";
            for(int i=0;i<str.length();i++){
                if(str.charAt(i) == ' '){
                    res +=  res1;
                    res += str.charAt(i);
                    res1 = "";
                }else{
                    res1 = str.charAt(i) + res1;
                }
            }
            res += res1;
            System.out.println(res);
        }

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值