Problem - 1018 Big Number

原题描述

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19

大致意思就是第一行输入接下来有多少个测试数据,然后依次输入要测试的数据,输出该测试数据的阶乘的位数。

用对数来求n的位数 lg(n!)=lg(n*(n-1)*......*2*1)=lgn+lg(n-1)+......+lg2+lg1

  不过出现了一个很有趣的现象

这是用c++写的代码

#include <iostream>
#include <cmath>
using namespace std;

int main( )
{
    int t;
    cin >>t;
    int i, a, n;
    double d;

    for ( i = 0; i < t; i++ )
    {
        cin >> n;
        d = 0;
        for ( a = 1;a < n; a++ )
            d += log10( (double)a );

            cout <<( int )( d + 1)<<endl;
    }
    return 0;
}
这是c的代码

#include <stdio.h>
#include <math.h>
int main( )
{
    int i, a, t, n;
    double d;
    while( scanf( "%d",&t ) != EOF )
    for ( i = 0 ;i < t ;i ++ )
    {
        d = 0;
        scanf("%d",&n );
        for ( a = 1; a < n; a ++ )
            d += log10( (double) a );


        printf("%d\n",(int) ( d+1 ) );
    }
    return 0;
}
最后c强制转换类型的时候 int忘记用()导致一直报错。。。

编译器运行成功之后 然后一直WA 。。。

因为循环条件里没有加n!!!!!!!!!!

正确代码如下

#include <iostream>
#include <cmath>
using namespace std;

int main( )
{
    int t;
    cin >>t;
    int i, a, n;
    double d;

    for ( i = 0; i < t; i++ )
    {
        cin >> n;
        d = 0;
        for ( a = 1;a <= n; a++ )
            d += log10( (double)a );

            cout <<( int )( d + 1)<<endl;
    }
    return 0;
}

每次都闹这种尴尬的问题 再见


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值