Problem - 1021 Fibonacci Again

很典型的Fibonacci 数列的问题

问题描述如下

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no

单纯的用递归直接算肯定时间超限,也没有足够大的内存存储,题目应该就是为了寻找某个规律以简便运算。

那就先看看都有哪些数符合题目要求。

#include <stdio.h>

int Fibonacci ( int n)
{
    if ( n == 0 )
        return 7;
    if ( n == 1)
        return 11;
    if ( n >= 2)
        return Fibonacci( n-1) + Fibonacci( n-2 );
}

int main( )
{
    int i, n;
    while ( (scanf("%d",&n )) != EOF )
    {
        for( i = 0; i <= n; i++ )
        if ( Fibonacci( i ) %3 ==0)
            printf("%d %d\n",i,Fibonacci( i ));
    }

    return 0;

}

看前100个数中有哪些数是可以整除3的运行(cb下运行 发现越后面的数越慢。。。直接递归导致编译器也要花一点 的时间啊???)

输出结果为 

2 18
6 123
10 843
14 5778
18 39603
22 271443
26 1860498
30 12752043
34 87403803
38 599074578
43 -1946095713
45 213926817

(其实结果不用输出,我们只要知道i的值就可以了。。。)

好吧 43开始就已经存储不下了 可想1000000。。。

 直接看规律 2 6 10 14 18 22  26 30 ..... 这些数不就是以2为首项,以4公差为的等差数列吗!!!

接下来就简单了an = 2 + (n-1)*4  那么an-2 就一定是4的倍数。

#include <stdio.h>

int main( )
{
    int i, n;
    while ( (scanf("%d",&n )) != EOF )
    {
        if ( (n - 2) %4 == 0 )
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值